Fast Matrix Calculation HDU - 4965 (矩阵快速幂)

题目链接:点我


 One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N).
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’.

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math. 

The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.

Output

For each case, output the sum of all the elements in M’ in a line.

Sample Input

4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0

Sample Output

14
56

题意:

给你一个 N * K 的矩阵 A 和一个 K * N 的矩阵 B . 令 C = A * B; 然后计算M = Cnn ,最后让你求矩阵 M 中所有元素的和,

思路:
一看题目我们就知道应该是矩阵快速幂,但我发现矩阵 C 是一个N * N 的矩阵, 而且 N 的范围很大,不能直接对它进行快速幂, 于是我们想肯定应该是把矩阵转化成一个 K * K 的矩阵才行, 我们想到矩阵乘法满足结合律, 于是 M = (AB)nn = A * B* A * B* A * B* A * B* A * B* A * B* A * B* ….. = A * BA)nn1 * B;于是答案就出来了,剩下的就是快速幂了,

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

typedef long long LL;
const int maxn = 1000+10;
const int mod = 6;
int n, m;
int x[maxn][10],y[10][maxn];
int q[maxn][10],p[maxn][maxn];

struct mat{
   int  a[10][10];
   mat (){memset(a, 0,sizeof(a));}
    mat operator *(const mat &q){
        mat c;
        memset(c.a, 0, sizeof(c.a));
        for(int i = 1; i <= 6; ++i)
        for(int k = 1; k <= 6; ++k)
            if(a[i][k])
        for(int j = 1; j <=6; ++j){
            c.a[i][j] += a[i][k] * q.a[k][j];
            if(c.a[i][j] >= mod)
                c.a[i][j] %= mod;
        }return c;
    }
};

mat qpow(mat x,int n){
    mat ans;
    memset(ans.a, 0, sizeof(ans.a));
        for(int i = 0; i <= 9; ++i)
            ans.a[i][i] = 1;
    while(n){
        if(n&1) ans = ans * x;
        x = x * x;
        n >>= 1;
    }return ans;
}

int main(){
    while(scanf("%d %d", &n, &m) != EOF && (m||n)){
        for(int  i = 1; i <= n; ++i)
        for(int j = 1; j <= m; ++j)
            scanf("%d", &x[i][j]);
        for(int  i = 1; i <= m; ++i)
        for(int j = 1; j <= n; ++j)
            scanf("%d", &y[i][j]);
       mat ans;
       for(int i = 1; i <= m;++i)
        for(int k = 1;k <= n;++k)
            if(y[i][k])
       for(int j = 1; j <= m; ++j){
                ans.a[i][j] += y[i][k] * x[k][j];
                if(ans.a[i][j] >= mod) ans.a[i][j] %= mod;
       }ans = qpow(ans, n*n-1);
       memset(q, 0,sizeof(q));
       memset(p,0,sizeof(p));
       for(int i = 1; i <= n;++i)
        for(int k = 1;k <= m;++k)
            if(x[i][k])
       for(int j = 1; j <= m; ++j){
                q[i][j] += x[i][k] * ans.a[k][j];
                if(q[i][j] >= mod) q[i][j] %= mod;
       }for(int i = 1; i <= n;++i)
        for(int k = 1;k <=m;++k)
            if(q[i][k])
       for(int j = 1; j <= n; ++j){
                p[i][j] +=q[i][k] * y[k][j];
                if(p[i][j] >= mod) p[i][j] %= mod;
       }int sum = 0;
        for(int i = 1; i <= n ;++i)
            for(int j = 1; j <= n; ++j)
            sum += p[i][j];
        printf("%d\n",sum);
    }return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值