hdoj 5635 LCP Array (模拟)

LCP Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1564    Accepted Submission(s): 480


Problem Description
Peter has a string  s=s1s2...sn , let  suffi=sisi+1...sn  be the suffix start with  i -th character of  s . Peter knows the lcp (longest common prefix) of each two adjacent suffixes which denotes as  ai=lcp(suffi,suffi+1)(1i<n ).

Given the lcp array, Peter wants to know how many strings containing lowercase English letters only will satisfy the lcp array. The answer may be too large, just print it modulo  109+7 .
 

Input
There are multiple test cases. The first line of input contains an integer  T  indicating the number of test cases. For each test case:

The first line contains an integer  n  ( 2n105)  -- the length of the string. The second line contains  n1  integers:  a1,a2,...,an1   (0ain) .

The sum of values of  n  in all test cases doesn't exceed  106 .
 

Output
For each test case output one integer denoting the answer. The answer must be printed modulo  109+7 .
 

Sample Input
  
  
3 3 0 0 4 3 2 1 3 1 2
 

Sample Output
  
  
16250 26 0
题意:是给出一个小写字母组成的串,从第一个字母开头到n-1个字母开头的子串 给出它与下一个子串的最长公共前缀,问该串的组成方式的种类

思路:我们可以观察到如果子串a[i]的公共前缀!=0,那么子串a[i+1]的公共前缀一定减1;而且前缀必须满足a[i]<=n-i

code

//#include <iostream>
#include<cstdio>
#define mod 1000000007
using namespace std;
long long a[1000010],ans;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int flag=0;
        for(int i=1;i<n;i++)
        {
            scanf("%lld",&a[i]);
            if(flag)
                continue;
            if((a[i-1]!=0&&a[i]!=a[i-1]-1)||a[i]>n-i)
                flag=1;
        }
        if(flag)
            printf("0\n");
        else{
            ans=26;
            for(int i=1;i<n;i++)
                if(a[i]==0)
                ans=(ans*25)%mod;
            printf("%lld\n",ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值