poj 2718 Smallest Difference (STL 暴力枚举)

30 篇文章 0 订阅

Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10413 Accepted: 2844

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28
题意:是给出2--10个从小到达排列的不重复的数,任意组成两个数,问它们的最小的绝对值是多少

思路:首先这两个数一定是最接近的,n个数分为偶数和奇数个,又分为含0和不含0,一个数不能有前导0的

贪心?以两个最接近的数作为开头然后其余的个数平分 大的放在开头小的后面 小的放在开头大的后面 ,如果是奇数个,多余的那个数一定放在开头小的后面。

举个反例:1 7 8 9

正解:因为 数据最多10个,STL的next_permutation()函数把所有可能的组合数枚举,10!=3.7*10^6,不会超时。

有几点注意的情况。

code

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f
using namespace std;

int main()
{
    int t,a[30],n;
    char str[30];
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        gets(str);
        n=0;
        int len=strlen(str);
        for(int i=0;i<len;i++)
            if(str[i]<='9'&&str[i]>='0')
                a[n++]=str[i]-'0';
        if(n==2){
            printf("%d\n",abs(a[0]-a[1]));
            continue;
        }
        int minn=INF;
        while(a[0]==0) //注意一:第一个数不能是前导0
            next_permutation(a,a+n);
        do
        {
            if(a[(n+1)/2]==0)//注意二:第二个数的开头,2也不能是前导0
                continue;
            int ans1=0,ans2=0;
            for(int i=0;i<(n+1)/2;i++)
            {
                ans1=ans1*10+a[i];
            }
            for(int i=(n+1)/2;i<n;i++)
                ans2=ans2*10+a[i];
            minn=min(minn,abs(ans1-ans2));
        }while(next_permutation(a,a+n));
        printf("%d\n",minn);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值