hdu5533Dancing Stars on Me(简单计算几何)

43 篇文章 0 订阅

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 599    Accepted Submission(s): 318


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n , denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi , describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
  
  
NO YES NO
 题目大意:给出n边形的各顶点坐标,判断其是否可以组成一个正N边形;各坐标的值均为整数;
解题思路:由于个坐标值均为整数,只有正方形的所有坐标可以都为整数,所以就是判断能否构成正方形。
AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
	int x,y;
}ans[120];
int cmp(node a,node b)
{
	if(a.x!=b.x)
	 return a.x<b.x;
	else
	 return a.y<b.y;
}
int main()
{
	int t;
	int n,i,j;
	scanf("%d",&t);
	while(t--)
	{
		memset(ans,0,sizeof(ans));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&ans[i].x,&ans[i].y);
		}
		   int s1,s2,s3,s4;
		   sort(ans,ans+n,cmp);
		   s1=ans[1].y-ans[0].y;
		   s2=ans[3].y-ans[2].y;
		   s3=ans[3].x-ans[1].x;
		   s4=ans[2].x-ans[0].x;
		   if(s1==s2&&s3==s4)
		    printf("YES\n");
		   else
		    printf("NO\n");
	}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值