hdu2509Be the Winner(尼姆博弈)

Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2718    Accepted Submission(s): 1487


Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

Sample Input
  
  
2 2 2 1 3
 

Sample Output
  
  
No Yes
//hdu2509Being a winner
//题目大意:n堆苹果,每堆有a[i]个;两人轮流从其中的任意一堆取;每次
//至少取一个,只是最后取完者输;
//解题思路:这次规定有些改变,但仍能用妮姆博奕来解决;
// 首先,看当所有堆数都为一(不为一的为零)时;若n为奇数,则先手输,否则,先手赢;
//当并不是所有堆数都为一时;将各堆异或之后的值为 0(即奇异局势)时;由于最后取完者输,
//所以先手会赢,否则,先手输。 
#include<stdio.h>
int main()
{
	int n,i,j;
	int a,s,cnt;
	while(scanf("%d",&n)!=EOF)
	{
		s=0,cnt=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);
			s^=a;
			if(a>1)
			 cnt=1;
		}
		if(cnt==0)
		{
			if(n%2==0)
			 printf("Yes\n");
			else
			 printf("No\n");
		}
		else
		{
			if(s==0)
			 printf("No\n");
			else
			 printf("Yes\n");
	    }
	}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值