hdu1015(dfs)

22 篇文章 0 订阅

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11667    Accepted Submission(s): 6011


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
 

Sample Input
  
  
1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END
 

Sample Output
  
  
LKEBA YOXUZ GHOST no solution
//hdu1015(dfs爆搜)
//题目大意:给你一个数target,以及由A~Z大写字符组成的长度在5~12的字符串.(其中A对应数字1,B对应数字2...Z对应数字26)
//现在让你从该字符串中选5个字符,假如其对应的数字分别为v,w,x,y,z;使得(v - w^2 + x^3 - y^4 + z^5)==target.
//打印满足上述方程的五个字符,如果存在多个,那么打印字典序最大的那个.
//解题思路:dfs搜索,由于存在多个解时,要打印字典序最大的那个,所以现对输入的字符串按从大到小排好.那么搜索得到的
//第一个就是解。如果找不到就输出"no solution". 
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
char s[10],str[15];
int target,len,flag,vis[15];
char cmp(char a,char b)   //cmp函数,使输入的字符串按降序排列 
{
	return a>b;
}
int powl(int a,int b)    //计算a^b 
{
	int s=1;
	for(int i=1;i<=b;i++)
	{
		s*=a;
	}
	return  s;
}
void dfs(int cur)
{
	int i;
	if(flag==1) return ;      //已找到解,一直退出。 
	if(cur==5)
	{
		int sum=(s[0]-'A'+1)-powl(s[1]-'A'+1,2)+powl(s[2]-'A'+1,3)-powl(s[3]-'A'+1,4)+powl(s[4]-'A'+1,5);
		if(sum==target)          //满足条件,打印字符串,然后退出。 
		{
			printf("%s\n",s);
			flag=1;
			return ;
		}
		return;
	}
	else
	{
		for(i=0;i<len;i++)      //从给定字符串中枚举5个字符。 
		{
			s[cur]=str[i];
			if(!vis[i])
			{
				vis[i]=1;     //标记为已使用 
				dfs(cur+1);
				vis[i]=0;    //回溯,vis[i]置零。 
			}	
		}
	}
}
int main()
{
   	int i,j,k;
   	while(~scanf("%d",&target))
   	{
   		getchar();
   		scanf("%s",str);
   	   len=strlen(str);
	   if(target==0&&strcmp(str,"END")==0) break;  //结束标志	
	   sort(str,str+len,cmp);                     //排序 
	   memset(vis,0,sizeof(vis));
	   flag=0;
       dfs(0);
       if(flag==0) printf("no solution\n");   //未找到,打印无解. 
       memset(s,0,sizeof(s));
       memset(str,0,sizeof(str));
	}
	return 0;
} 
 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值