poj3356(LCS)

AGTC
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12190 Accepted: 4575

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

//poj3356(LCS)
//题目大意:给你两个DNA序列A、B,A串的长度小于等于B串.现在然你通过插入、删除、以及修改
//使得A串变为B串,问你最少需要多少次操作?
//解题思路:首先可以先求出两串的最长公共子序列.这些不需要任何操作.然后由于使A转化为B,B的长度大于等于A.
//所以B串的长度减去其最长公共子序列的长度就是最少需要的操作数.(这一点我是看样例想到的,一开始以为kmp) 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[1010][1010];
char s[1010],t[1010];
int main()
{
   int n,m,i,j,k=0;
   while(scanf("%d",&n)!=EOF)
   {
   scanf("%s",s);
   scanf("%d",&m);
   scanf("%s",t);
   memset(dp,0,sizeof(dp));
     for(i=0;i<n;i++)
     {
       for(j=0;j<m;j++)
	   {
	     if(s[i]==t[j]) dp[i+1][j+1]=dp[i][j]+1;
		 else dp[i+1][j+1]=max(dp[i+1][j],dp[i][j+1]);	
	   }	
     }
   k=m-dp[n][m];
   printf("%d\n",k);
   }
   return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值