hdu1251(字典树入门)

统计难题


Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 29054    Accepted Submission(s): 11417




Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 


Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.


注意:本题只有一组测试数据,处理到文件结束.
 


Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 


Sample Input
banana
band
bee
absolute
acm


ba
b
band
abc
 


Sample Output
2
3
1

0

题目大意:有若干个单词,现在给你一些英文字符串,问以该字符串为前缀的单词有多少?

解题思路:字典树

ac代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
struct node 
{
    node *child[26];
	int n;
};
struct node *root;
void insert(char s[],int len)
{
	int i,j,k;
	if(len==0) return ;
	struct node *current,*newnode;
	current=root;
	for(i=0;i<len;i++)
	{
		if(current->child[s[i]-'a']!=0)
		{
			current=current->child[s[i]-'a'];
			current->n=current->n+1;
		}
		else
		{
			newnode = (struct node *)malloc(sizeof(struct node));
			for(j=0;j<26;j++)
			 newnode->child[j]=0;
			current->child[s[i]-'a']=newnode;
			current=newnode;
			current->n=1;
		}
	}
}
int find(char s[],int len)
{
	int i,j,k;
	if(len==0) return 0;
	struct node *current;
	current=root;
	for(i=0;i<len;i++)
	{
		if(current->child[s[i]-'a']!=0)
		{ 
			current=current->child[s[i]-'a'];
		}
		else
		 return 0;
	}
	return current->n;
}
int main()
{
   	int i,j,len,k,n;
   	char s[15];
   	root=(struct node *)malloc(sizeof(struct node));
   	for(i=0;i<26;i++)
   	 root->child[i]=0;
   	root->n=2;
   	while(gets(s),strcmp(s,"")!=0)
   	{
   	   len=strlen(s);
   	   insert(s,len);	
	}
	while(scanf("%s",s)!=EOF)
	{
	   len=strlen(s);
	   k=find(s,len);
	   printf("%d\n",k);
	}
	struct node *p,*t;
	p=root;
	for(i=0;i<26;i++)
	{
		if(p->child[i]!=0)
		{
			t=p->child[i];
			free(p);
			p=t;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值