POJ3414

Pots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16275 Accepted: 6864 Special Judge

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

    深搜,从一个水杯到另一个水杯的问题,和nyoj的三个水杯的题目一样。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int v[103][103];
struct node{
  int a,b,step;
};
struct node1{
  int a,b,num;
}pre[105][105];
int A,B,C;
void print(int a,int b);
char str[6][10] = {"FILL(1)","FILL(2)","DROP(1)","DROP(2)","POUR(1,2)","POUR(2,1)"};
void bfs();
int main()
{
    cin>>A>>B>>C;
    memset(v,0,sizeof(v));
    bfs();
    return 0;
}
void print(int a,int b){
    if(a||b)
        print(pre[a][b].a,pre[a][b].b);
    if(!a&&!b)return;
    printf("%s\n",str[pre[a][b].num]);
}
void bfs(){
    queue<node>q;
    node temp;
    temp.a = temp.b = temp.step = 0;
    v[0][0] = 1;
    q.push(temp);
    while(!q.empty()){
        temp = q.front();
        q.pop();
        if(temp.a==C||temp.b==C){
            cout<<temp.step<<endl;
            print(temp.a,temp.b);
            return;
        }
        int na,nb;
        node t;
        for(int i = 0;i < 6;i++){
            if(!i){
                na = A,nb = temp.b;
                if(v[na][nb])continue;
                v[na][nb] = 1;
                t.a = na,t.b = nb;
                t.step = temp.step+1;
                pre[na][nb].a = temp.a;
                pre[na][nb].b = temp.b;
                pre[na][nb].num = i;
                q.push(t);
            }
            if(i==1){
                na = temp.a,nb = B;
                if(v[na][nb])continue;
                v[na][nb] = 1;
                t.a = na,t.b = nb;
                t.step = temp.step+1;
                pre[na][nb].a = temp.a;
                pre[na][nb].b = temp.b;
                pre[na][nb].num = i;
                q.push(t);
            }
            if(i==2){
                na = 0,nb = temp.b;
                if(v[na][nb])continue;
                v[na][nb] = 1;
                t.a = na,t.b = nb;
                t.step = temp.step+1;
                pre[na][nb].a = temp.a;
                pre[na][nb].b = temp.b;
                pre[na][nb].num = i;
                q.push(t);
            }
            if(i==3){
                na = temp.a,nb = 0;
                if(v[na][nb])continue;
                v[na][nb] = 1;
                t.a = na,t.b = nb;
                t.step = temp.step+1;
                pre[na][nb].a = temp.a;
                pre[na][nb].b = temp.b;
                pre[na][nb].num = i;
                q.push(t);
            }
            if(i==4&&temp.b!=B&&temp.a){
                if(B-temp.b<temp.a)
                    nb = B,na = temp.a-(B-temp.b);
                else if(B-temp.b>=temp.a)
                    nb = temp.b+temp.a,na = 0;
                if(v[na][nb])continue;
                v[na][nb] = 1;
                t.a = na,t.b = nb;
                t.step = temp.step+1;
                pre[na][nb].a = temp.a;
                pre[na][nb].b = temp.b;
                pre[na][nb].num = i;
                q.push(t);
            }
            if(i==5&&temp.b&&temp.a!=A){
                if(A-temp.a<temp.b)
                    na = A,nb = temp.b-(A-temp.a);
                else if(A-temp.a>=temp.b)
                    na = temp.a+temp.b,nb = 0;
                if(v[na][nb])continue;
                v[na][nb] = 1;
                t.a = na,t.b = nb;
                t.step = temp.step+1;
                pre[na][nb].a = temp.a;
                pre[na][nb].b = temp.b;
                pre[na][nb].num = i;
                q.push(t);
            }
        }
    }
    cout<<"impossible"<<endl;
    return;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值