POJ 2229 Sumsets

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Thinking 今晚POJ好像宕机了,一liu都是waiting,说实话 这还是看了别人的题解写的。虽然我看完题就知道这是完全背包,但是。。。我自己理解的太浅,完全背包写的WA了,所以还是递推吧。 太慢了,OJ还没有出结果,我要拥抱电路和离散了。结果应该是对的。PS : 22号看了一下,AC了,是正确的,嗯,加油。
#include <cstdio>
#include<iostream>
using namespace std;

const int maxn=1000005;
const long long MOD=1000000000;
int dp[maxn];

int main()
{
    int N;

    while ((scanf("%d",&N))!=EOF) {
        dp[1]=1;
        dp[2]=2;
        for (int i=3; i<=N; i++) {
            if ((i%2)==1) {
                dp[i]=dp[i-1];
            }
            else dp[i]=(dp[i-1]+dp[i/2])%MOD;
        }
        printf("%d\n",dp[N]);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值