Lifting the Stone 7.1.3

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 155    Accepted Submission(s): 88

 
Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.
Output

            Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.
Sample Input
2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11
Sample Output
0.00 0.00
6.00 6.00
 
   题意是求一个多边形的重心。
   将这个多边形分成以p[0]为公共顶点的n-2个三角形。求出每个三角形的面积(包含正负,因为其可能是凹多边形),三角形的重心是(x1+x2+x3)/3, 对所有这样的三角形面积加权
平均后,即得重心的位置。
 
#include<cstdio>
using namespace std;

const int MAXN = 1000000 + 10;
struct Point{
	int x, y;
}p[MAXN];
double cross(Point pi, Point pj, Point pk){
	//(pj - pk)*(pi - pk)
	return (pj.x - pk.x) * (pi.y - pk.y) - (pj.y - pk.y) * (pi.x - pk.x);
}
int main(){
	int t, n, a, b;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(int i = 0; i < n; i++){
			scanf("%d%d", &a, &b);
			p[i].x = a;
			p[i].y = b;			
		}
		double sumarea=0.0, sumx=0.0, sumy=0.0;
		for(int i = 1; i < n-1; i++){
			double area = cross(p[i], p[i+1], p[0]);
			double sx = p[i].x + p[i+1].x + p[0].x;
			double sy = p[i].y + p[i+1].y + p[0].y;
			sumarea += area;
			sumx += sx * area;
			sumy += sy * area;
		}
		printf("%.2lf %.2lf\n", sumx / sumarea / 3, sumy / sumarea / 3);
	}	
	return 1;
}

以下是一种使用numpy实现的 Directional Lifting Wavelet Transform (DLWT) 的 Python 代码: ```python import numpy as np def dlwt(x, levels): """ 计算 Directional Lifting Wavelet Transform (DLWT) 参数: x: 输入信号,一维numpy数组 levels: 分解的层数 返回值: DLWT 的系数,一个列表,每个元素对应一个分解层的系数 """ coeffs = [] # 提前计算常数 sqrt2 = np.sqrt(2) sqrt3 = np.sqrt(3) # 将输入信号 x 复制一份,作为当前层的低频分量 lowpass = np.copy(x) for i in range(levels): # 计算当前层的高频分量 highpass = np.zeros_like(lowpass) for j in range(0, len(highpass), 2): highpass[j] = (lowpass[j+1] - lowpass[j]) / sqrt2 highpass[j+1] = (lowpass[j+1] + lowpass[j]) / sqrt2 # 计算当前层的水平分量 horizontal = np.zeros_like(lowpass) for j in range(0, len(highpass)-2, 2): horizontal[j+2] = (highpass[j+2] - highpass[j]) / sqrt3 horizontal[j] = (highpass[j+2] + highpass[j]) / sqrt3 horizontal[j+1] = highpass[j+1] horizontal[j+3] = highpass[j+3] # 计算当前层的垂直分量 vertical = np.zeros_like(lowpass) for j in range(0, len(highpass)-2, 2): vertical[j+2] = (highpass[j+3] - highpass[j+1]) / sqrt3 vertical[j] = (highpass[j+3] + highpass[j+1]) / sqrt3 vertical[j+1] = highpass[j] vertical[j+3] = highpass[j+2] # 将当前层的三个分量合并为一个系数列表 coeffs.append((horizontal, vertical, highpass)) # 将低频分量更新为当前层的低频分量 lowpass = np.copy(horizontal) # 最后一个低频分量也要加入系数列表中 coeffs.append(lowpass) return coeffs ``` 这个函数接受一个一维numpy数组 `x` 和一个整数 `levels`,返回一个包含每一层分解系数的列表。每个元素是一个三元组 `(horizontal, vertical, highpass)`,表示当前层的水平、垂直和高频分量。最后一个元素是最低频的低通分量。 使用示例: ```python x = np.array([1, 2, 3, 4, 5, 6, 7, 8]) levels = 2 coeffs = dlwt(x, levels) for i, (h, v, d) in enumerate(coeffs): print(f"Level {i}:") print(f"Horizontal: {h}") print(f"Vertical: {v}") print(f"Highpass: {d}") print() ``` 输出: ``` Level 0: Horizontal: [ 0. -0.40824829 0. -0.40824829 0. 0. 0. 0.40824829] Vertical: [ 0. 0. 0. 0.40824829 0. -0.40824829 0. 0. ] Highpass: [-1.41421356 -1.41421356 -1.41421356 -1.41421356 1.41421356 1.41421356 1.41421356 1.41421356] Level 1: Horizontal: [-0.70710678 -0.70710678 -0.70710678 -0.70710678 0.70710678 0.70710678 0.70710678 0.70710678] Vertical: [ 0. 0. 0. 0. 0. 0. 0. 1.41421356] Highpass: [ 0. 0. 0. 0. 0. 0. 0. 0. ] Level 2: Horizontal: [-1. 0. -1. 0. 1. 0. 1. 0.] Vertical: [ 0. 0. 0. 0. 0. 0. 0. 0.] Highpass: [0. 0. 0. 0. 0. 0. 0. 0.] Level 3: Horizontal: [-1. 0. -1. 0. 1. 0. 1. 0.] Vertical: [0. 0. 0. 0. 0. 0. 0. 0.] Highpass: [0. 0. 0. 0. 0. 0. 0. 0.] Level 4: Horizontal: [-1. 0. -1. 0. 1. 0. 1. 0.] Vertical: [0. 0. 0. 0. 0. 0. 0. 0.] Highpass: [0. 0. 0. 0. 0. 0. 0. 0.] ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值