POJ - 1655 Balancing Act (求树的重心)

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 


Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

思路:

树形dp。遍历每个节点的子树,找出每个子树的节点数量。

#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 2e5 + 5;

struct Edge
{
	int to, prev;
}edge[MAXN * 2];

int head[MAXN], tot;

void addEdge(int u, int v)
{
	tot++;
	edge[tot].to = v;
	edge[tot].prev = head[u];
	head[u] = tot;
}

int dp[MAXN], num[MAXN];
int n;

void dfs(int cur, int prev)
{
	dp[cur] = 0;
	num[cur] = 1;

	for (int i = head[cur]; i > 0; i = edge[i].prev)
	{
		int peer = edge[i].to;

		if (peer != prev)
		{
			dfs(peer, cur);
			dp[cur] = max(dp[cur], num[peer]);
			num[cur] += num[peer];
		}
	}

	dp[cur] = max(dp[cur], n - num[cur]);
}

void init()
{
	memset(head, 0, sizeof(head));
	tot = 0;
}

int main()
{
	int T;
	cin >> T;
	int u, v;
	
	while (T--)
	{
		cin >> n;
		init();
		for (int i = 1; i < n; i++)
		{
			cin >> u >> v;
			addEdge(u, v);
			addEdge(v, u);
		}

		dfs(1, 0);
		int ans1 = 1;
		int ans2 = dp[1];

		for (int i = 2; i <= n; i++)
		{
			if (ans2 > dp[i])
			{
				ans1 = i;
				ans2 = dp[i];
			}
		}
		
		cout << ans1 << " " << ans2 << endl;
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值