http://acm.split.hdu.edu.cn/showproblem.php?pid=2102
Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。
Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。
Sample Input
1 5 5 14 S*#*. .#... ..... ****. ...#. ..*.P #.*.. ***.. ...*. *.#..
Sample Output
YES
#include<cstdio>
#include<cstdlib>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<map>
#define ms(x) memset( (x),0,sizeof(x) );
using namespace std;
typedef long long int ll;
char v[2][10][11];
int n,m,t,flag(0);
void dfs(int c,int x,int y,int tx,int ty){
if(t < 0){
// puts("NO");flag = 1;p = 1;
return ;
}
if(flag) return ;
if(x >= n || y >= m || x < 0 || y < 0) return ;
if(v[c][x][y] == 'P') {
puts("YES");flag = 1;return ;
}
if(v[c][x][y] == '*') return ;
if(v[c][x][y] == '$') return ;
if(v[c][x][y] == '#') {
v[c][x][y] = '*';
if(c == 0) dfs(1,x,y,0,0);//第二处错误
else dfs(0,x,y,0,0);
v[c][x][y] = '#';
return;
}
char ch = v[c][x][y];
v[c][x][y] = '$';
for(int i = -1;i < 2;i++){
for(int j = -1;j < 2;j++){
if(i == tx && j == ty) continue;
if(i == 0 && j == 0) continue;
if(abs(i)+abs(j) == 2) continue;
t--;
dfs(c,x+i,y+j,-i,-j);//第一处错误
t++;
}
}
v[c][x][y] = ch;
}
int main()
{
freopen("1.txt","r",stdin);
int C;
scanf("%d",&C);
while(C--){
scanf("%d%d%d",&n,&m,&t);
ms(v);flag = 0;
for(int i = 0;i < 2;i++){
for(int j = 0;j < n;j++){
scanf("%s",v[i][j]);
}
}
v[0][0][0] = '.';
dfs(0,0,0,0,0);
if(!flag) puts("NO");
// cout<<t<<'\n';
}
return 0;
}
ps
第一个错误地方是应该传入 -i -j 应为不能往回走
第二个错误的地方时可以向上传,也要考虑向下传