foj 1759


Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,C<=1000000000,1<=B<=10^1000000).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 4
2 10 1000

Sample Output

1
24

解题思路:B太大不能直接算,C也很大,不能找循环,这里是A^x=A^(x % phi(c) + phi(c) )  (mod c)  (x>=phi(c)) 这个公式的利用,具体实现就是一个求一个数的欧拉函数,一个快速幂,一个字符串转换的函数,注意用scanf,否则会超时。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long llong;
llong eular(llong n)
{
    llong i,ans=n;
    for(i=2;i*i<=n;++i)
        if(n%i==0)
        {
            ans-=ans/i;
            while(n%i==0)
                n/=i;
            if(n==1)
                break;
        }
    if(n!=1)
        ans-=ans/n;
    return ans;
}
llong quickpow(llong a,llong b,llong c)
{
    llong ans=1;
    while(b)
    {
        if(b&1)
            ans=(ans*a)%c;
        b>>=1;
        a=(a*a)%c;
    }
    return ans;
}
llong stol(char a[],llong n)
{
    llong i,ans=0;
    bool flag=false;
    for(i=0;a[i]!='\0';++i)
    {
        ans=ans*10+(a[i]-'0');
        if(ans>=n)
        {
            flag=true;
            ans%=n;
        }
    }
    if(flag==true)
        ans+=n;
//    cout<<ans<<endl;
    return ans;
}

int main()
{
    llong a,lb,c,phi;
    char b[1000005];
    while(scanf("%I64d %s %I64d",&a,b,&c)!=EOF)
    {
        phi=eular(c);
        lb=stol(b,phi);
//        cout<<quickpow(a,lb,c)<<endl;
        printf("%I64d\n",quickpow(a,lb,c));
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值