【lightoj1010】


Given an m x n chessboard where you want to place chess knights. You have to find the number of maximum knights that can be placed in the chessboard such that no two knights attack each other.

Those who are not familiar with chess knights, note that a chess knight can attack 8 positions in the board as shown in the picture below.


Input

Input starts with an integer T (≤ 41000), denoting the number of test cases.

Each case contains two integers m, n (1 ≤ m, n ≤ 200). Here m and n corresponds to the number of rows and the number of columns of the board respectively.

Output

For each case, print the case number and maximum number of knights that can be placed in the board considering the above restrictions.

Sample Input

3

8 8

3 7

4 10

Sample Output

Case 1: 32

Case 2: 11

Case 3: 20


题目大意:求m*n的棋盘中最多放几个马


思路:T<=41000,搜索肯定超时,只能找规律。

m,n都大于2时ans=max(黑块数,白块数)

其中一个等于1或2时要特殊考虑,是2时要遵循四个一块放,隔四个的规律才能放最多。模拟出这个过程即可

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int t,i,m,n,ans;
    cin>>t;
    for(i=1; i<=t; i++)
    {
        scanf("%d%d",&m,&n);
        if(m>n) swap(m,n);
        if(m==1) ans=n;
        else if(m==2)
        {
            int x=(m*n)%8;
            if(x>4) x=4;
            int y=(m*n)/8;
            ans=x+y*4;
        }
        else
        {
            if((m*n)&1) ans=(m*n+1)/2;
            else ans=(m*n)/2;
        }
        printf("Case %d: %d\n",i,ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值