hdu 4956 ( BestCoder #5 1001) Poor Hanamichi

Poor Hanamichi

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 72    Accepted Submission(s): 38


Problem Description
Hanamichi is taking part in a programming contest, and he is assigned to solve a special problem as follow: Given a range [l, r] (including l and r), find out how many numbers in this range have the property: the sum of its odd digits is smaller than the sum of its even digits and the difference is 3.

A integer X can be represented in decimal as:
\(X = A_n\times10^n + A_{n-1}\times10^{n-1} + \ldots + A_2\times10^2 + A_1\times10^1 + A_0\)
The odd dights are \(A_1, A_3, A_5 \ldots\) and \(A_0, A_2, A_4 \ldots\) are even digits.

Hanamichi comes up with a solution, He notices that:
\(10^{2k+1}\) mod 11 = -1 (or 10), \(10^{2k}\) mod 11 = 1, 
So X mod 11 
= \((A_n\times10^n + A_{n-1}\times10^{n-1} + \ldots + A_2\times10^2 + A_1\times10^1 + A_0) \mod 11\)
= \(A_n\times(-1)^n + A_{n-1}\times(-1)^{n-1} + \ldots + A_2 - A_1 + A_0\)
= sum_of_even_digits – sum_of_odd_digits
So he claimed that the answer is the number of numbers X in the range which satisfy the function: X mod 11 = 3. He calculate the answer in this way : 
Answer = (r + 8) / 11 – (l – 1 + 8) / 11.

Rukaw heard of Hanamichi’s solution from you and he proved there is something wrong with Hanamichi’s solution. So he decided to change the test data so that Hanamichi’s solution can not pass any single test. And he asks you to do that for him.
 

Input
You are given a integer T (1 ≤ T ≤ 100), which tells how many single tests the final test data has. And for the following T lines, each line contains two integers l and r, which are the original test data. (1 ≤ l ≤ r ≤ \(10^{18}\))
 

Output
You are only allowed to change the value of r to a integer R which is not greater than the original r (and R ≥ l should be satisfied) and make Hanamichi’s solution fails this test data. If you can do that, output a single number each line, which is the smallest R you find. If not, just output -1 instead.
 

Sample Input
  
  
3 3 4 2 50 7 83
 

Sample Output
  
  
-1 -1 80
 

Source
 
  

题意:
       找不满足i*11-8不满足偶数位比奇数位大三的数。
题解:
      直接从左端点开始模拟,刚开始打表发现,相邻两个满足条件的数差值不是很大。注意从Ao开始的。
代码:



#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
const int maxn=1000000+100;
const int maxint=999999999;
int a[1000];
int main()
{
    long long l,r;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d",&l,&r);
        int sign=1;
        long long  temp=l/11;
        long long temp1,temp3;
        for(long long i=temp;i*11-8<=r;i++)//从左边开始找
        {
         temp1=i*11-8;//要查找的数
         temp3=temp1;
        long long ans1=0;
        long long  ans2=0;
        long long k=0;
        while(temp1)//将各位数存在数组里
        {
            a[k++]=temp1%10;
            temp1=temp1/10;
        }
        for(int j=0;j<k;j++)//分别计算奇数位和偶数位
        {
            if(j%2)
            ans1+=a[j];
            else
            ans2+=a[j];
        }
        if((ans2-ans1)!=3&&temp3>=l&&temp3<=r)//当找到符合的跳出
        {
            printf("%I64d\n",temp3);
            sign=0;
            break;
        }
        }
        if(sign)//未找到
        printf("-1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值