并查集uva1160 - X-Plosives


哎,想了半天都没发现是树,一定要学会举一反三啊,注意树的特点,n个点n-1条边,那么题目就很简单的,每次插入树里面判断有无环,这是一个森林,用并查集,如果祖先相等那么代表已经在同一棵树上,舍弃,注意有多个输入。。。。坑,

题目如下:

                                                      X-Plosives

A secret service developed a new kind of explosive that attain its volatile property only when a specificassociation of products occurs. Each product is a mix of two different simple compounds, to which wecall a binding pair. If N > 2, then mixing N different binding pairs containing N simple compoundscreates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, threecompounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receivebinding pairs in sequential order and place them in a cargo ship. However, you must avoid placing inthe same room an explosive association. So, after placing a set of pairs, if you receive one pair thatmight produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, youmust accept it.An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G,F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make thefollowing explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds).Finally, you would accept the last pair, F+H.Compute the number of refusals given a sequence of binding pairs.InputThe input will contain several test cases, each of them as described below. Consecutivetest cases are separated by a single blank line.Instead of letters we will use integers to represent compounds. The input contains several lines.Each line (except the last) consists of two integers (each integer lies between 0 and 105) separated bya single space, representing a binding pair.Each test case ends in a line with the number ‘-1’. You may assume that no repeated binding pairsappears in the input.OutputFor each test case, the output must follow the description below.A single line with the number of refusals.

Sample Input1 2

3 4

3 5

3 1

2 3

4 1

2 6

6 5

-1

Sample Output

3

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
int fa[100004];
int find(int x){
	if (fa[x]==x) return x;
	return fa[x]=find(fa[x]);
}
int main(){
	int x,y;
	int ans=0;
	while(cin>>x){
		for (int i=0;i<100004;i++) fa[i]=i;
		ans=0;
		while(x!=-1){
			cin>>y;
			int f1=find(x);
			int f2=find(y);
			if (f1==f2) ans++;
			else fa[f1]=f2;		
			cin>>x;
		}
		cout<<ans<<endl;
	}
}



<span style="text-align: center; color: rgb(0, 0, 255); text-transform: none; line-height: normal; text-indent: 0px; letter-spacing: normal; font-family: Arial, Helvetica, sans-serif; font-size: 24px; font-style: normal; font-variant: normal; word-spacing: 0px; float: none; display: inline !important; white-space: normal; widows: 1; -webkit-text-stroke-width: 0px;"><span style="color:#000000;">
</span></span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值