1052. 卖个萌 (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue
萌萌哒表情符号通常由“手”、“眼”、“口”三个主要部分组成。简单起见,我们假设一个表情符号是按下列格式输出的:
[左手]([左眼][口][右眼])[右手]
现给出可选用的符号集合,请你按用户的要求输出表情。
输入格式:
输入首先在前三行顺序对应给出手、眼、口的可选符号集。每个符号括在一对方括号[]内。题目保证每个集合都至少有一个符号,并不超过10个符号;每个符号包含1到4个非空字符。
之后一行给出一个正整数K,为用户请求的个数。随后K行,每行给出一个用户的符号选择,顺序为左手、左眼、口、右眼、右手——这里只给出符号在相应集合中的序号(从1开始),数字间以空格分隔。
输出格式:
对每个用户请求,在一行中输出生成的表情。若用户选择的序号不存在,则输出“Are you kidding me? @\/@”。
输入样例:[╮][╭][o][~\][/~] [<][>] [╯][╰][^][-][=][>][<][@][⊙] [Д][▽][_][ε][^] ... 4 1 1 2 2 2 6 8 1 5 5 3 3 4 3 3 2 10 3 9 3输出样例:
╮(╯▽╰)╭ <(@Д=)/~ o(^ε^)o Are you kidding me? @\/@
连着1051,两道操蛋的题
#include<stdio.h>
#include<vector>
#include<string.h>
#include<iostream>
using namespace std;
int main()
{
//freopen("D://input.txt", "r", stdin);
vector<string> hands, eyes, mouth;
char s1[1001], s2[1001], s3[1001];
gets(s1);
gets(s2);
gets(s3);
string str; int flag = 0;
for(int i = 0; i < strlen(s1); i ++)
{
if(s1[i] == '[')
{
str = "";
flag = 1;
continue;
}
if(flag == 1 && s1[i] != ']')
{
str = str + s1[i];
}
if(s1[i] == ']')
{
hands.push_back(str);
flag = 0;
}
}
for(int i = 0; i < strlen(s2); i ++)
{
if(s2[i] == '[')
{
str = "";
flag = 1;
continue;
}
if(flag == 1 && s2[i] != ']')
{
str = str + s2[i];
}
if(s2[i] == ']')
{
eyes.push_back(str);
flag = 0;
}
}
for(int i = 0; i < strlen(s3); i ++)
{
if(s3[i] == '[')
{
str = "";
flag = 1;
continue;
}
if(flag == 1 && s3[i] != ']')
{
str = str + s3[i];
}
if(s3[i] == ']')
{
mouth.push_back(str);
flag = 0;
}
}
// for(int i = 0; i < hands.size(); i ++)
// cout<<hands[i]<<endl;
// for(int i = 0; i < eyes.size(); i ++)
// cout<<eyes[i]<<endl;
// for(int i = 0; i < mouth.size(); i ++)
// cout<<mouth[i]<<endl;
int n, buf[6];
int limit[6];
limit[0] = hands.size();
limit[1] = eyes.size();
limit[2] = mouth.size();
limit[3] = eyes.size();
limit[4] = hands.size();
while(scanf("%d", &n) != EOF)
{
while(n--)
{
bool flag = false;
for(int i = 0; i < 5; i ++)
{
scanf("%d", &buf[i]);
if(buf[i] > limit[i] || buf[i] <= 0)
flag = true;
}
if(flag)
cout<<"Are you kidding me? @\\/@"<<endl;
else
{
cout << hands[buf[0]-1];
cout << "(" << eyes[buf[1]-1];
cout << mouth[buf[2]-1];
cout << eyes[buf[3]-1] << ")";
cout << hands[buf[4]-1] << endl;
}
}
}
return 0;
}