Complete the ternary calculation.
Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
There is a string in the form of "number1 operatora number2 operatorb number3". Each operator will be one of {'+', '-' , '*', '/', '%'}, and each number will be an integer in [1, 1000].
Output
For each test case, output the answer.
Sample Input
5 1 + 2 * 3 1 - 8 / 3 1 + 2 - 3 7 * 8 / 5 5 - 8 % 3
Sample Output
7 -1 0 11 3
Note
The calculation "A % B" means taking the remainder of A divided by B, and "A / B" means taking the quotient.
#include<stdio.h>
#include<string.h>
int main()
{
char o1[5],o2[5];
int t,a,b,c,ans;
scanf("%d",&t);
while(t--)
{
scanf("%d%s%d%s%d",&a,o1,&b,o2,&c);
if((o1[0]=='+'||o1[0]=='-')&&(o2[0]=='*'||o2[0]=='/'||o2[0]=='%'))
{
if(o2[0]=='*')
{
ans=b*c;
}
else if(o2[0]=='/')
{
ans=b/c;
}
else
ans=b%c;
if(o1[0]=='+')
ans+=a;
else
ans=a-ans;
}
else
{
if(o1[0]=='+')
ans=a+b;
else if(o1[0]=='-')
ans=a-b;
else if(o1[0]=='*')
ans=a*b;
else if(o1[0]=='/')
ans=a/b;
else
ans=a%b;
if(o2[0]=='+')
ans=ans+c;
else if(o2[0]=='-')
ans=ans-c;
else if(o2[0]=='*')
ans=ans*c;
else if(o2[0]=='/')
ans=ans/c;
else
ans=ans%c;
}
printf("%d\n",ans);
}
return 0;
}