HDU 5642 King's Order 递推

King's Order

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 829    Accepted Submission(s): 454


Problem Description
After the king's speech , everyone is encouraged. But the war is not over. The king needs to give orders from time to time. But sometimes he can not speak things well. So in his order there are some ones like this: "Let the group-p-p three come to me". As you can see letter 'p' repeats for 3 times. Poor king!

Now , it is war time , because of the spies from enemies , sometimes it is pretty hard for the general to tell which orders come from the king. But fortunately the general know how the king speaks: the king never repeats a letter for more than 3 times continually .And only this kind of order is legal. For example , the order: "Let the group-p-p-p three come to me" can never come from the king. While the order:" Let the group-p three come to me" is a legal statement.

The general wants to know how many legal orders that has the length of n

To make it simple , only lower case English Letters can appear in king's order , and please output the answer modulo  1000000007

We regard two strings are the same if and only if each charactor is the same place of these two strings are the same.
 

Input
The first line contains a number  T(T10) ——The number of the testcases.

For each testcase, the first line and the only line contains a positive number  n(n2000) .
 

Output
For each testcase, print a single number as the answer.
 

Sample Input
  
  
2 2 4
 

Sample Output
  
  
676 456950 hint: All the order that has length 2 are legal. So the answer is 26*26. For the order that has length 4. The illegal order are : "aaaa" , "bbbb"…….."zzzz" 26 orders in total. So the answer for n == 4 is 26^4-26 = 456950
 

Source
 

Recommend
wange2014

 

数据预处理处理好,递推过程就两行...很好整


#include <bits/stdc++.h>
#define mod 1000000007

using namespace std;

int main()
{
    int n,T;
    long long dp[2005][5],ans[2005];
    dp[1][1]=26;
    ans[1]=26;
    dp[2][1]=26*25;
    dp[2][2]=26;
    ans[2]=26*26;
    dp[3][1]=26*25*25+26*25;
    dp[3][2]=26*25;
    dp[3][3]=26;
    ans[3]=26*26*26;
    for(int i=4;i<=2000;i++)
    {
        dp[i][1]=((dp[i-1][1]+dp[i-1][2]+dp[i-1][3])*25)%mod;
        dp[i][2]=dp[i-1][1];
        dp[i][3]=dp[i-1][2];
        ans[i]=(dp[i][1]+dp[i][2]+dp[i][3])%mod;
    }
    cin>>T;
    while(T--)
    {
        cin>>n;
        cout<<ans[n]<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值