hdu3530 Subsequence 单调队列

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8032    Accepted Submission(s): 2711


Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

Output
For each test case, print the length of the subsequence on a single line.
 

Sample Input
 
 
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

Sample Output
 
 
5 4
 

Source
/*
题意:给出一个数字序列,求出最长的那一段数,这段数满足:最大值和最小值的差在给定的两个值之间,求出最长的长度。
这一题用到了单调队列。两个单调队列,一个用来保存前方单调最小值的下标,一个用来保存前方单调最大值的下标。
当前段的最值之差大于限定值的时候就去除当前段的最前面的那个数,如果差值在小的限定值之下,就不用管它,如果在限定值之间就判断是不是最长的。
*/
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;


const int MAXN=100010;
int q1[MAXN],q2[MAXN];
int rear1,head1;//单调序列1后面和单调序列1前面。 
int rear2,head2;
int a[MAXN];
int main()
{
	int n,m,k;
	while(scanf("%d%d%d",&n,&m,&k)!=EOF)
	{
		rear1=head1=0;
		rear2=head2=0;
		int ans=0;
		int now=1;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			while(head1<rear1 && a[q1[rear1-1]]<a[i])
			rear1--;
			while(head2<rear2 && a[q2[rear2-1]]>a[i])
			rear2--;
			q1[rear1++]=i;
			q2[rear2++]=i;
			while(head1<rear1 && head2<rear2 && a[q1[head1]]-a[q2[head2]]>k)
			{
				if(q1[head1]<q2[head2])
				now=q1[head1++]+1;
				else
				now=q2[head2++]+1;
			}
			if(head1<rear1 && head2<rear2 &&a[q1[head1]]-a[q2[head2]]>=m)
			{
				if(ans<i-now+1)
				ans=i-now+1;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值