nyoj791 colorthefence

Color the fence

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述

Tom has fallen in love with Mary. Now Tom wants to show his love and write a number on the fence opposite to 

Mary’s house. Tom thinks that the larger the numbers is, the more chance to win Mary’s heart he has.

Unfortunately, Tom could only get V liters paint. He did the math and concluded that digit i requires ai liters paint. 

Besides,Tom heard that Mary doesn’t like zero.That’s why Tom won’t use them in his number.

Help Tom find the maximum number he can write on the fence.

输入
There are multiple test cases.
Each case the first line contains a nonnegative integer V(0≤V≤10^6).
The second line contains nine positive integers a1,a2,……,a9(1≤ai≤10^5).
输出
Printf the maximum number Tom can write on the fence. If he has too little paint for any digit, print -1.
样例输入
55 4 3 2 1 2 3 4 529 11 1 12 5 8 9 10 6
样例输出
5555533
来源
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int s[10];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,j,min=0x3f3f3f3f;
		for(i=1;i<10;i++)//从1开始赋值,方便后面使用 
		{
			scanf("%d",&s[i]);
			if(min>s[i])
			min=s[i];//求得最少写一个数字需要的油漆值.
		}
		if(n<min)//如果油漆连写一个数字都不够 
		{
			printf("-1\n");
			continue;
		}
		for(i=n/min-1;i>=0;i--)//位数优先,然后是每一个位的数字优先 
		{
			//最多可以染的位数等于循环次数 
			for(j=9;j>0;j--)//从后往前 使数尽量大 
			{
				if(n>=s[j]&&(n-s[j])/min>=i)//考虑出现多个并列最小油漆值的情况 
				{ 
					//扫描所有的可以足大于当前要染的数字,并且所消耗后的剩余染料除以min保证位数不变小即仍然大于等于i,那么就可以染当前的数字 
					printf("%d",j);
					n-=s[j];
					break;//注意 仅仅是跳出j的循环 
				}
			}
		}
		printf("\n");
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值