HDOJ-1021 Fibonacci Again

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0 1 2 3 4 5

Sample Output

no no yes no no no

思路:数太大时直接迭代错误,打表后找规律。

#include <iostream>  
#include <string> 
#include<cstring> 
#include<algorithm> 
#include<cmath> 
#include<iomanip>
using namespace std;  
//int fib(int n){
//    int a1=7,a2=11,a3;
//    if(n==0) return 7;
//    if(n==1) return 11;
//    for(int i=2;i<=n;i++){
//        a3=a2+a1;
//        a1=a2;
//        a2=a3;
//    }
//    return a3;
//    
//}
int  main() {
    int n;
    while(cin>>n) {
     if((n+2)%4==0) cout<<"yes"<<endl;
     else cout<<"no"<<endl;
    }
    
    return 0;

}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值