Problem J:Contest Print Server

Time Limit : 2000/1000ms(Java/Other)   Memory Limit : 65535/32768K (Java/Other)

 

Problem Description

In ACM/ICPC on-sitecontests ,3 students share 1 computer,so you can print your source code anytime. Here you need to write a contest print server to handle all the requests.

 

Input

In the first line thereis an integer T(T<=10),which indicates the number of test cases.

In each case,the firstline contains 5 integers n,s,x,y,mod (1<=n<=100,1<=s,x,y,mod<=10007), and n lines of requests follow. The request is like"Team_Name request p pages" (p is integer, 0<p<=10007, thelength of "Team_Name" is no longer than 20), means the team"Team_Name" need p pages to print, but for some un-know reason theprinter will break down when the printed pages counter reached s(s is generatedby the function s=(s*x+y)%mod ) and then the counter will become 0. In the sametime the last request will be reprint from the very begin if it isn't completeyet(The data guaranteed that every request will be completed in some time).

You can get more fromthe sample.

 

Output

Every time a request iscompleted or the printer is break down,you should output one line like "ppages for Team_Name",p is the number of pages you give the team"Team_Name".

Please note that youshould print an empty line after each case.

 

Sample Input

2

3 7 5 6 177

Team1 request 1 pages

Team2 request 5 pages

Team3 request 1 pages

3 4 5 6 177

Team1 request 1 pages

Team2 request 5 pages

Team3 request 1 pages

 

 

Sample Output

1 pages for Team1

5 pages for Team2

1 pages for Team3

 

1 pages for Team1

3 pages for Team2

5 pages for Team2

1 pages for Team3

 

 模拟题,有个坑点。s=0要再执行一次。

#include <iostream>
#include <cstdio>
#include <cstring>
#include<vector>
using namespace std;
char team[25];
int main()
{

    int t,s,x,y,mod,i,p,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d%d",&n,&s,&x,&y,&mod);
        int countn=0;
        while(n--)
        {
            scanf("%s request %d pages",team,&p);
            getchar();
            int flag=1;
            while(flag==1)
            {

                if(p<=s-countn)
                {
                    printf("%d pages for %s\n",p,team);
                    countn+=p;
                    flag=0;
                }
                else
                {
                    printf("%d pages for %s\n",s-countn,team);
                    s=(s*x+y)%mod;
                    if(s==0)
                         s=(s*x+y)%mod;
                    countn=0;
                }
            }
        }
        printf("\n");

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值