Minimum Inversion Number HDU 1394

题目链接:点我


    The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

    For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

    You are asked to write a program to find the minimum inversion number out of the above sequences. 

Input

    The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 

Output

For each case, output the minimum inversion number on a single line. 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

题意:

求循环最小逆序对数

思路:

线段树单点更新,区间查询.每次将一个数插入相应节点前,先区间查询这个比这个数大的数的个数,因为他们比这个数先出现而且比这个数大,所以构成逆序对.问题的难点在与如何求循环的逆序对数,假设我们把数字k移到到最后去,那么逆序对增加的个数为比k大的数的个数即:n - k - 1,相应的减少的数的个数为小于k的数的个数,即: k,最后递推即可.

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<cmath>
using namespace std;

int b[5000+10];
int a[20000];

void pushup(int cur){
    a[cur] = a[cur << 1] + a[cur << 1|1];//维护逆序对数的总和
}

void build(int cur, int l, int r){
    a[cur] = 0;
    if(l == r)
        return ;
    int mid = (l + r) >> 1;
    build( cur << 1, l ,mid);
    build( cur << 1|1,mid + 1, r);
}

int quiry(int ll, int rr, int l, int r, int cur){
    if (ll <= l && rr >= r)//如果当前区间在要查询区间内,直接返回.
        return a[cur];
    int mid = (l + r) >> 1;
    int ans=0;
    if (ll <= mid) ans += quiry( ll, rr, l, mid, cur << 1);
    if (rr > mid) ans += quiry( ll , rr, mid+1, r, cur << 1|1);
    return ans;
}

void update(int key, int l, int r, int cur){
    if(l == r){
        a[cur]++;
        return ;
    }
    int mid = (l + r) >> 1;
    if(key <= mid) update( key, l, mid, cur << 1);
    else update( key, mid + 1, r, cur << 1|1);
    pushup(cur);
}

int main(){
    int n;
    while(scanf("%d", &n) != EOF){
        build(1,0,n-1);
        int sum = 0;
        for(int i = 0;i < n; ++ i){
            scanf("%d", &b[i]);
            sum += quiry( b[i], n-1, 0, n-1, 1);
            update( b[i], 0 , n-1, 1);
        }
        int ans = sum;
        for(int i = 0; i < n; ++ i){//递推求最小逆序对数
            sum += n - b[i] - b[i] - 1;
            ans = min( ans, sum);
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值