Max Sum of Max-K-sub-sequence HDU - 3415

题目链接:点我


    Given a circle sequence A11,A22,A33......Ann. Circle sequence means the left neighbour of A11 is Ann , and the right neighbour of Ann is A11. 
    Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.

Input

    The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. 
    Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).

Output

    For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.

Sample Input

4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1

Sample Output

7 1 3
7 1 3
7 6 2
-1 1 1

题意:

求大小为k以内的子序列的最大和.

思路:

序列倍增,然后求前缀和,最后用前缀和维护一个下标差不超过m的单调递增的单调队列.

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<cmath>
using namespace std;

const int maxn = 200000 + 10;
int sum[maxn];
int a[maxn];
int b[maxn];

int main(){
    int t;
    scanf("%d", &t);
    while(t--){
        int  n, m;
        scanf("%d %d", &n, &m);
        for(int i = 1;i <= n;++i){
            scanf("%d", &a[i]);
            a[n+i]=a[i];
        }
        sum[0] = 0;
        int ansl,ansr,ans=-100000000;
        for(int  i = 1; i <= n + n;++i){//找出序列中最大的数并且求前缀和
            sum[i] = sum[i-1] + a[i];
            if(a[i] > ans){
                ans = a[i];
                ansl =i;
                ansr = i;
            }
        }
        int l= 0 ,r ,k = 0;
        for(int i = 1; i <= n + n;++i){
            while( k > l && sum[b[k-1]]>sum[i-1]) k--;
            b[k++] = i-1;
           while(k > l && i - b[l] > m ) ++l;//单调队列的大小不超过m
            if((ans <sum[i] -  sum[b[l]] && i)){
                ans = sum[i] - sum[b[l]];
                ansl = b[l] + 1;
                ansr = i;
            }
        }
        if (ansl > n) ansl -= n;
        if (ansr > n) ansr -= n;
        printf("%d %d %d\n",ans ,ansl, ansr);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值