HDU-2845 DP twice

17 篇文章 0 订阅

Problem Description:
Bean-eating is an interesting game, everyone owns an MN matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 11 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn’t beyond 1000, and 1<=M*N<=200000.
Output
For each case, you just output the MAX qualities you can eat and then get.

Sample Input
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
Sample Output
242
题意:
在图示的条件下(拿了O不能拿—),求能拿的最大数量
解题思路:
对每行dp一次求其最大值,在拿这些最大值再dp一次
代码:

#include<bits/stdc++.h>
#define maxn 200003
using namespace std;
int dp1[maxn],dp2[maxn];
int main(){
	int m,n;
	while(~scanf("%d%d",&m,&n)){
		for(int i=1;i<=m;++i){
			for(int j=1;j<=n;++j) scanf("%d",&dp1[j]) ,dp1[j]=max(dp1[j-2]+dp1[j],dp1[j-1]);
			dp2[i]=dp1[n];
			dp2[i]=max(dp2[i]+dp2[i-2],dp2[i-1]);
		}
		printf("%d\n",dp2[m]);
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值