poj-1789 Truck History

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

    prim算法之前没怎么深入研究,借这道题正好做个模板。需要注意的是prim算法中map的初值一定要是最大的,因为dis数组每次找的是最小值,而dis数组的初值由map赋予。剩下的prim算法就是每次找dis数组里的最小值,将两点连接,然后见dis数组更新看当前新连的点与所关联的点有没有小于dis的(松弛)。然后继续进行循环。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define INF 0x3f3f3f3f

using namespace std;

int map[2010][2010];
int vis[2010];
int dis[2010];
char str[2010][100];
int n;

void prim()
{
    int i,j;
    int pos=1,ans=0;
    int min;
    for (i=1;i<=n;i++)
    {
        dis[i]=map[pos][i];
    }
    vis[pos]=1;
    for (i=1;i<n;i++)
    {
        min=INF;
        for (j=1;j<=n;j++)
        {
            if(dis[j]<min && !vis[j])
            {
                pos=j;
                min=dis[pos];
            }
        }
        vis[pos]=1;
        ans += min;
        for (j=1;j<=n;j++)
        {
            if(dis[j]>map[pos][j] && !vis[j])
            {
                dis[j]=map[pos][j];
            }
        }
    }
    printf("The highest possible quality is 1/%d.\n",ans);
}
int main()
{

    int i,j,k;
    while (~scanf("%d",&n),n)
    {
        int sum=0;
        memset(vis,0,sizeof(vis));
        for (i=0;i<=n;i++)
        {
            for (j=0;j<=n;j++)
            {
                map[i][j]=INF;
            }
        }
        for (i=1;i<=n;i++)
        {
            scanf("%s",str[i]);
        }
        int len= strlen(str[1]);
        for (i=1;i<n;i++)
        {
            for (j=i+1;j<=n;j++)
            {
                sum=0;
                for (k=0;k<len;k++)
                {
                    if(str[i][k]!=str[j][k])
                    {
                        sum++;
                    }
                }
                map[i][j]=sum;
                map[j][i]=sum;
            }
        }
        prim();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值