poj-2503 Babelfish

5 篇文章 0 订阅

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

    题意:为后一个字符串与前一个相关联,先输入联系隔一个空行,之后输入后面的字符串找对应前面的。

    思路:由于给的时间很长用map可以水过去(我果断就水过去了),也可以用字典树做,速度会快很多。中间的空行有点坑,需要用gets()读入然后用sscanf将两个字符分开。因为scanf不能让回车通过,也就是一直回车会卡在scanf不动。本人闲得没事写了个不用gets和sscanf的写法,会附在代码中作为注释。

#include <iostream>
 #include <algorithm>
 #include <cstring>
 #include <cstdio>
 #include <map>
 #include <string>
 using namespace std;
 int main()
 {
     char a[33],b[33],c[33];
     map<string,string>Q;
     while(gets(c))
     {
         if(strlen(c)==0) break;
         sscanf(c,"%s %s",a,b);
         Q[b]=a;
     }
    /* while(1)                                                                   //没事干的写法,通过这个可以找到一定要用上面的写法的原因
     {
         t=0;
         while(a[t]=getchar(),a[t]!=' '&&a[0]!='\n') t++;
         if(a[0]!='\n') a[t]='\0';
         if(a[0]=='\n') break;
         scanf("%s%*c",b);
        Q[b]=a;
     }*/
     while(scanf("%s",a)!=EOF)
     {
         if(Q.count(a))
         {
             cout<<Q[a]<<endl;
         }
         else
         {
             printf("eh\n");
         }
     }
     return 0;
 }



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值