hdu 5608 function

function
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 478 Accepted Submission(s): 174

Problem Description

There is a function f(x),which is defined on the natural numbers set N,satisfies the following eqaution

N2−3N+2=∑d|Nf(d)

calulate ∑Ni=1f(i) mod 109+7.

Input

the first line contains a positive integer T,means the number of the test cases.

next T lines there is a number N

T≤500,N≤109

only 5 test cases has N>106.

Output

Tlines,each line contains a number,means the answer to the i-th test case.

Sample Input

1
3

Sample Output

2

1 2 31+2=f(1)=0 
2 2 32+2=f(2)+f(1)=0>f(2)=0 
3 2 33+2=f(3)+f(1)=2>f(3)=2 
f(1)+f(2)+f(3)=2 

Source

BestCoder Round #68 (div.2)

Recommend

hujie | We have carefully selected several similar problems for you: 6032 6031 6030 6029 6028


【分析】
自己明明(假装)学过杜教筛,却被一道裸题卡了好久= =
…它就是裸题吧
注意前1e6的数据自己O(nlogn)的筛一遍先,要不TLE


【代码】

//hdu
#include<map>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 1000000
#define ll long long
#define inv2 500000004
#define inv6 166666668
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const int mod=1e9+7;
const int mxn=1000005;
map <int,int> M;
int m,n,T;
long long tmp[mxn];
inline void init()
{
    int i,j;
    fo(i,1,N) tmp[i]=(ll)(i-1)*(i-2)%mod;
    fo(i,1,N)
      for(j=i+i;j<=N;j+=i)
        tmp[j]=(tmp[j]-tmp[i]+mod)%mod;
    fo(i,1,N) tmp[i]=(tmp[i]+tmp[i-1])%mod;
}
inline int solve(int n)
{
    if(n<=N) return tmp[n];
    if(M.count(n)) return M[n];
    ll sum=(ll)n*(n+1)%mod*(n+n+1)%mod*inv6%mod;
    sum=(sum-(ll)3*n%mod*(n+1)%mod*inv2%mod)%mod;
    sum=(sum+n+n)%mod;
    for(int i=2,last=0;i<=n;i=last+1)
    {
        last=n/(n/i);
        sum=(sum-(ll)(last-i+1)*solve(n/i)%mod)%mod;
    }
    sum=(sum+mod)%mod;
    return M[n]=(int)sum;
}
int main()
{
    int i,j,T;
    init();
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        printf("%d\n",solve(n));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值