hdu 2577- How to Type (dp)&&(模拟)

How to Type

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3
Pirates
HDUacm
HDUACM
Sample Output
8
8
8

栗子
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

先说下 题目的意思,大体就是 我们要输入一个字符串,但这个字符串的只有大写字母和小写字母组成,转大写或者小写字母 有2种方式
1.按 Caps Lock 转大写小
2.按shift+大写–》小写 shift+小写–》大写
注意: 在最后输入结束时,如果Caps Lock未关闭, 要关闭。
题目就是要统计输入 一个字符串 所按下的所有键位 次数之和

解题解题 题目有2种解法 1.dp 2.模拟
首先 太菜 dp不会 而且 看不懂 ,所以 只能模拟做 。题目,嗯 ,不解释了
上代码 :

#include<cstdio>
#include<string.h>
#include <iostream>
using namespace std;
int main()
{
    int t,sum,ans,da,i;
    char a[2050];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",a);
        sum=ans=0;
        da=0;
        for(i=0;a[i]!=0;i++)
        {
            //控制 Caps Lock 状态
            if(a[i]>='A'&&a[i]<='Z'&&a[i+1]>='A'&&a[i+1]<='Z'&&da==0)//如果连续两个大写 就转成大写的
            {
                da=1;
                ans++;
            }
            if(a[i]>='a'&&a[i]<='z'&&(a[i+1]>='a'&&a[i+1]<='z'||a[i+1]==0)&&da==1)//连续两个小写的就转成大写的
                //注意:如果已经是最后一个的话,就要转换成小写,这样最后可以少一步转换回小写的操作;
            {
                da=0;
                ans++;
            }

            //控制是否利用shift 转换大小写
            if(a[i]>='A'&&a[i]<='Z')
            {
                if(da==0)  //Caps Lock关闭 ,用
                    ans+=2;
                else    //否则不用
                    ans++;
            }
            else if(a[i]>='a'&&a[i]<='z')
            {
                if(da==0)   //Caps Lock关闭 ,不用
                    ans++;
                else
                    ans+=2; 
            }
        }
        if(da)
        {
            ans++;  //最后看 如果 Caps Lock 开启要关闭
        }
        printf("%d\n",ans);
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值