hdu--6063 RXD and math

题目:hdu–6063

RXD and math

Problem Description
RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki

output the answer module 109+7 .
1n,k1018
μ(n)=1(n=1)

μ(n)=(1)k(n=p1p2pk)

μ(n)=0(otherwise)

p1,p2,p3pk are different prime numbers
 
Input
There are several test cases, please keep reading until EOF.There are exact 10000 cases.
For each test case, there are 2 numbers n,k .
 
Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 
Sample Input
  
  
10 10
 
Sample Output
  
  
Case #1: 999999937

如果能找到规律的话,那就很快就写出来了
其实 n的k 次方对1e9+7取模就行了
代码:

#include<iostream>
#include<cstdio>
using namespace std;
long long mod = 1e9+7;
 //使用快速幂
long long pow(long long  n,long long  m){
    long long r=1,base=(n%mod);
    while(m){
        if(m&1){
            r=(r*base%mod+mod)%mod;
        }
        base=(base*base%mod+mod)%mod;
        m>>=1;
    }   
    return r;
}

int main(){
    ios::sync_with_stdio(0);
    cin.tie(0);
    long long n,m,k=0;
    while(cin>>n>>m){
        printf("Case #%lld: %lld\n",++k,pow(n,m)%mod);
    }
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值