南邮 OJ 1542 GCC

GCC

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 63            测试通过 : 17 

比赛描述

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m



输入

The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

输出

Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

样例输入

1
10 861017

样例输出

593846

提示

undefined

题目来源

Asia Wuhan Regional 2009




#include<stdio.h>
int main(){
	char c[111];
	__int64 t,n,m,i,j,r;
	scanf("%I64d",&t);
	while(t--){
		scanf("%s%I64d",c,&m);
		for(n=i=0; c[i]; i++){
			n = n*10 + c[i]-'0';
			if(n>=m){
				n = m;
				break;
			}
		}
		for(r=i=1,j=1; i<=n; i++){
			j *= i;
			j %= m;
			r += j;
			r %= m;
		}
		printf("%I64d\n",r%m);		//WA1  m==1
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值