hdu4324Triangle LOVE(拓扑排序)

 

 

 

                                   Triangle LOVE

                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                  Total Submission(s): 1991    Accepted Submission(s): 845


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Author
BJTU
 
 
小心超时!!
2013-11-20 23:48:01 Accepted 4324 1890MS 53712K 1440 B Java 1983210400 

import java.util.*;

public class Main {

     static int[]indegree;
     static int i,j,k,n,m;
     static int[][]map; 
    public static void main(String[] args) {
    
           Scanner sc = new Scanner(System.in);
           int N = sc.nextInt();
           int c=0;
           while(N-->0){
                m = n = sc.nextInt();                             
               indegree = new int[n+1];          
               map = new int[n][n];
            
               for(int i=0;i<n;i++){
                   char[]a = sc.next().toCharArray();
                   for(int j=0;j<n;j++)
                       if(a[j]=='1')
                           if(map[i][j]==0){
                               indegree[j]++; 
                               map[i][j]=1;
                           }                                                                                                       
               }
              boolean flag=false;
               for( i=0;i<n;i++){
                   
                   for( j=0;j<n;j++)
                        if(indegree[j]==0)
                            break; 
                   if(j==n){//一旦找了各个点都没有,即j==n时有环
                       flag=true;
                       break;
                   }else{
                      indegree[j]--;
                      for( k=0;k<n;k++)
                          if(map[j][k]==1)
                              indegree[k]--;                 
                   }
               }
               if(flag)
                   System.out.println("Case #"+(++c)+": Yes");
               else
                   System.out.println("Case #"+(++c)+": No");
           }
    }
}

 他人代码:DFS:
//这题做的好奇怪、开始用vector进行邻接存储以某点出发可以到的点
//结果超时,而用for循环(i=1;i<=n;i++)居然187Ms
//网上说官方解题报告用“增量法",表示不知道、唉、见识太少
//这方法是最早想到的、结果一直被自己排除,东搞西搞最后还是回来用dfs
//就是用不恢复标记、判断某2点距离是否相差2且有线相连
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
char b[2001][2001];
bool f[2001],flag;
int dis[2001],n;
void dfs(int df)
{
    if(flag) return;
    f[df]=1;
    int i;
    for(i=1;i<=n;i++)
      if(b[df][i]=='1')
      {
         if(f[i]&&dis[df]==dis[i]+2)//判断是否成3角恋关系
         {
           flag=1;
           break;
         }
          else if(!f[i])
          {
            dis[i]=dis[df]+1;
            dfs(i);
          }
      }
}
int main()
{
    int t,cnt=1;
    int i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        getchar();
        for(i=1;i<=n;i++)
         {    f[i]=0;
             scanf("%s",b[i]+1);
         }
          flag=0;dis[1]=0;
          dfs(1);
          printf("Case #%d: ",cnt++);
          if(flag) printf("Yes\n");
          else printf("No\n");
    }
    return 0;
}

 
 
 
 
 
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值