hdu4028The time of a day

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 1157    Accepted Submission(s): 500


Problem Description
There are no days and nights on byte island, so the residents here can hardly determine the length of a single day. Fortunately, they have invented a clock with several pointers. They have N pointers which can move round the clock. Every pointer ticks once per second, and the i-th pointer move to the starting position after i times of ticks. The wise of the byte island decide to define a day as the time interval between the initial time and the first time when all the pointers moves to the position exactly the same as the initial time.
The wise of the island decide to choose some of the N pointers to make the length of the day greater or equal to M. They want to know how many different ways there are to make it possible.
 

Input
There are a lot of test cases. The first line of input contains exactly one integer, indicating the number of test cases.
  For each test cases, there are only one line contains two integers N and M, indicating the number of pointers and the lower bound for seconds of a day M. (1 <= N <= 40, 1 <= M <= 2 63-1)
 

Output
For each test case, output a single integer denoting the number of ways.
 

Sample Input
  
  
3 5 5 10 1 10 128
 

Sample Output
  
  
Case #1: 22 Case #2: 1023 Case #3: 586
 

Source
The 36th ACM/ICPC Asia Regional Shanghai Site —— Online Contest

[1,n]中挑出任意数,它们的最小公倍数不小m

有多少种挑选方法
 
dp[i][j]:[1,i]中挑出任意数,它们的最小公倍数不小j的方法数


dp[i][lcm(i,j)]+=dp[i-1][j]

注意,由于只有a时最小公倍数也算作是a,所以,dp[i][i]++

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b)
{
	return b==0?a:gcd(b,a%b);
}
ll lcm(ll a,ll b)
{
	return a/gcd(a,b)*b;
}
map<ll,ll>dp[50];
int main()
{
	dp[1][1]=1;
	for(ll i=2;i<=40;i++)
	{
		dp[i]=dp[i-1];
		dp[i][i]++;
		for(map<ll,ll>::iterator it=dp[i-1].begin();it!=dp[i-1].end();it++)
			dp[i][lcm(it->first,i)]+=it->second;
	}
	int T;
	cin>>T;
	for(int cs=1;cs<=T;cs++)
	{
		int n;
		ll m;
		cin>>n>>m;
		ll ans=0;
		for(map<ll,ll>::iterator it=dp[n].lower_bound(m);it!=dp[n].end();it++)
			ans+=it->second;
		cout<<"Case #"<<cs<<": "<<ans<<endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值