hdu 2141

传送门

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 11439    Accepted Submission(s): 3014


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
题意:二分。Ai+Bj+Ck = X.所以Ai+Bj=X-Ck

这样就可以用二分了,用一个数组将Ai+Bj存起来,然后在一步步的去查找X-Ck。

这里面有所有的二分全集,这个在时间优化上比较性点击打开链接

#include <iostream>
#include <algorithm>
#include<cstdio>
using namespace std;

const int N = 505;

__int64 ab[N * N];
int num;

int search(__int64 x)
{
	int f = 0, l = num - 1;
	int mid;
	while(f <= l)
	{
		mid = (f + l) / 2;
		if(ab[mid] == x)
			return 1;
		else if(ab[mid] < x
			f = mid + 1;
		else
			l = mid - 1;
	}
	return 0;
}

int main()
{
	int n, m, l, flag = 0, s;
	__int64 a[N], b[N], c[N], x;
	while(cin >> n >> m >> l)
	{
		flag++;
		num = 0;
		for(int i = 0; i < n; i++)
			scanf("%I64d", &a[i]);
		for(int i = 0; i < m; i++)
			scanf("%I64d", &b[i]);
		for(int i = 0; i < l; i++)
			scanf("%I64d", &c[i]);

		for(int i = 0; i < n; i++)
			for(int j = 0; j < m; j++)
				ab[num++] = a[i] + b[j];
		sort(ab, ab+num);
		sort(c, c+l);
		scanf("%d", &s);
		printf("Case %d:\n", flag);
		while(s--)
		{
			scanf("%I64d", &x);
			if(x < ab[0] + c[0] || x > ab[num-1] + c[l-1])
				printf("NO\n");
			else
			{
				__int64 p;
				int j;
				for(j = 0; j < l; j++)
				{
					p = x - c[j];
					if(search(p))
					{
						printf("YES\n");
						break;
					}
				}
				if(j == l)
					printf("NO\n");
			}
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值