4.1.3--二分-Can you find it?

Can you find it?

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 1299 Accepted Submission(s): 418
 
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

解题思路:也是很经典的题型,给数组a,b,c,每个数组取一个看能不能组成要求的数,这种题如果你想三重循环来做的话应该会超时,这个题本来想把三个数组化为一个数组,但是好像有点大,那么把a,b数组化为一个并且排序用来二分,然后外层c循环,内层和数组二分

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
#define exp 0.0000000001
int main()
{
    int len,low,high,mid,l,n,m,s,i,j,cas=1;
    int a[501],b[501],c[501],d[250005],x[1001];
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
    {
        for(i=0;i<l;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n;i++)
            scanf("%d",&b[i]);
        for(i=0;i<m;i++)
            scanf("%d",&c[i]);
        scanf("%d",&s);
        for(i=0;i<s;i++)
            scanf("%d",&x[i]);
        len=0;
        for(i=0;i<l;i++)
            for(j=0;j<n;j++)
            d[len++]=a[i]+b[j];
        sort(d,d+len);
        printf("Case %d:\n",cas++);
        for(int t=0;t<s;t++)
        {
            int flag=0;
            for(i=0;i<m;i++)
            {
                low=0; high=len-1;
                    while(low<=high)
                    {
                        mid=(low+high)/2;
                        if((c[i]+d[mid])==x[t])
                        {
                            flag=1;
                            break;
                        }
                        else
                        {
                            if((c[i]+d[mid])<x[t])
                                low=mid+1;
                            else
                                high=mid-1;
                        }
                    }
                if(flag) break;
            }
            if(flag) printf("YES\n");
            else printf("NO\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值