[POJ1655] Balancing Act

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1…N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.
For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input
The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output
For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input
1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output
1 2

Source
POJ Monthly–2004.05.15 IOI 2003 sample task

树的重心,用到了邻接表
分析:首先要知道什么是树的重心,树的重心定义为:找到一个点,其所有的子树中最大的子树节点数最少,那么这个点就是这棵树的重心,删去重心后,生成的多棵树尽可能平衡. 实际上树的重心在树的点分治中有重要的作用, 可以避免N^2的极端复杂度(从退化链的一端出发),保证NlogN的复杂度, 利用树型dp可以很好地求树的重心.

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
bool vis[20005],f[20005];
int head[20005],son[20005];
int t,n,cnt,root,ans=1<<30,ansm;
struct point{
    int to,next;
}e[40005];
void add(int x,int y)
{
    e[++cnt].to=y;
    e[cnt].next=head[x];
    head[x]=cnt;
}
void dfs(int m)
{
    vis[m]=1;
    int i,tmp=0;
    son[m]=1;
    for(i=head[m];i!=-1;i=e[i].next)
    {
        int v=e[i].to;
        if(vis[v]) continue;
        dfs(v);
        son[m]+=son[v];
        tmp=max(son[v],tmp);
    }
    tmp=max(tmp,n-son[m]);
    if(tmp<ans||(tmp==ans&&ansm>m))
    {
        ans=tmp;
        ansm=m;
    }
}
int main()
{
    scanf("%d",&t);
    int x,y,i;
    while(t--)
    {
        cnt=0;
        memset(f,0,sizeof(f));
        memset(vis,0,sizeof(vis));
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        ans=1<<30;
        ansid=0;
        scanf("%d",&n);
        for(int i=1;i<n;i++)
        {
            scanf("%d %d",&x,&y);
            add(x,y);
            add(y,x);
            f[y]=1;
        }
        i=1;
        dfs(1);
        printf("%d %d\n",ansm,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值