PAT A1107 Social Clusters (30分) (并查集)

PAT甲级:A1107 Social Clusters (30分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
  • 题意:给出n个人的爱好,人物和爱好编号都为1到N,有同样爱好的人视作在一个群组,要求找出,这群人中有几个共同兴趣小组,输出群组数并按降序输出各组人数。
  • 分析:需要用到并查集,同时,用hobby数组做哈希表标记谁有当前爱好,如果hobby是0则说明之前没记录过,需要记录一下,如果不为0,这找到其所在的群组,将当前的人合并到这个集合。之后遍历n个人,找到所有的群组并存到unordered_map中,再将结果转到vector中降序输出。
#include <bits/stdc++.h>
using namespace std;
const int N = 1010;
int father[N];
int findFather(int x) {
    return x == father[x] ? x : father[x] = findFather(father[x]);
}
void uni(int a, int b) {
    int faA = findFather(a);
    int faB = findFather(b);
    if (faA != faB) father[faA] = faB;
}
int main() {
    for (int i = 0; i < N; i++) father[i] = i;
    int n, k, h, hobby[N] = {0};
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        scanf("%d: ", &k);
        for (int j = 0; j < k; j++) {
            scanf("%d", &h);
            if (hobby[h] != 0) uni(i, findFather(hobby[h]));
            else hobby[h] = i;
        }
    }
    unordered_map<int, int> mp;
    vector<int> ans;
    for (int i = 1; i <= n; i++) mp[findFather(i)]++;
    for (auto it : mp) ans.push_back(it.second);
    printf("%d\n", ans.size());
    sort(ans.begin(), ans.end());
    for (int i = ans.size() - 1; i >= 0; i--) {
        printf("%d", ans[i]);
        if (i != 0) printf(" ");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值