1107 Social Clusters (30分)-PAT甲级真题

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] … hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:
3
4 3 1

题目大意:

将社交网络上爱好相同的一群人称为一个 社交群体;给出一些人的爱好,要求求出在这些人中一共有几个社交群体,并将这些群体的人数从大到小输出;

思路:

用map<int, vector > 存储拥有每种爱好的人,建立并查集,遍历map将同一个爱好中的人合并(Union),最后再用一个map<int, int>记录并查集中每个集合的人数,最后输出。

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int n, k;
int father[maxn];
vector<int> ans;
unordered_map<int, vector<int> > hobby;
unordered_map<int, int> numOfSet;
int findFather(int x) {
    int a = x;
    while (father[x] != x) {
        x = father[x];
    }
    while (father[a] != a) {
        int z = a;
        a = father[a];
        father[z] = x;
    }
    return x;
}
void Union(int a, int b) {
    int fa = findFather(a);
    int fb = findFather(b);
    if (fa != fb) {
        father[fa] = fb;
    }
}
bool cmp(int a, int b) {return a > b;}
int main() {
    for (int i = 0; i < maxn; ++i) {
        father[i] = i;
    }
    cin >> n;
    for (int i = 1; i <= n; ++i) {
        scanf("%d: ", &k);
        int temp;
        for (int j = 0; j < k; j++) {
            cin >> temp;
            hobby[temp].push_back(i);
        }
    }
    for (auto it : hobby) {
        if (it.second.size() > 1) {
            for (int i = 0; i < it.second.size()-1; i++) {
                Union(it.second[i], it.second[i+1]);
            }
        }
    }
    for (int i = 1; i <= n; i++) {
        numOfSet[findFather(i)]++;
    }
    printf("%d\n", numOfSet.size());
    for (auto it : numOfSet) {
        ans.push_back(it.second);
    }
    sort(ans.begin(), ans.end(), cmp);
    for (int i = 0; i < ans.size(); i++) {
        printf("%d", ans[i]);
        if (i != ans.size()-1) printf(" ");
    }
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值