Matrix Chain Multiplication UVA 442(栈+表达式求值)

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

题目大意:给出矩阵和一些矩阵乘的表达式,求每个表达式乘法的计算次数(一次实数乘法算一次),如表达式有错就输出error。

题目思路:设A是m*n矩阵,B是n*p矩阵,A*B乘法计算的次数就是m*n*p,如果更多矩阵连乘可以迭代的认为A是一个表达式,符合这个基本规则。之后开一个栈(其实队列也挺好),表达式分三类,(,),矩阵,每次遇到)就计算,并将结果也存入栈中,其他的存到栈里。直到读取最后一个)。

#include<stdio.h>
#include<stack>
#include<string.h>
using namespace std;
struct node { int x, y; }m[30];
char a[1000];
int main()
{
	int n;
	char c;
	scanf("%d", &n);
	getchar();
	for (int i = 0; i < n; i++)
	{
		scanf("%c", &c);
		scanf("%d%d", &m[c - 'A'].x, &m[c - 'A'].y);
		getchar();
	}
	x:while (scanf("%s", &a) == 1)
	{
		int len = strlen(a),ans=0;
		node o;
		o.x = o.y = 0;
		stack<node>s;
		for (int i = 0; i < len+1; i++)
		{
			if (a[i] == '(')s.push(o);
			else if (i==len||a[i] == ')')
			{
				stack<node>s1;
				int tem = 1;
				while (!s.empty()&&s.top().x != 0) { s1.push(s.top()); s.pop(); }
				if(!s.empty())s.pop();
				node c1 = s1.top(),c2=o;
				s1.pop();
				while (!s1.empty())
				{
					c2 = s1.top();//括号里有至少两个表达式
					s1.pop();
					if (c1.y != c2.x) { printf("error\n"); goto x; }
					tem *= c1.x*c1.y*c2.y;
					c1.y = c2.y;
				}
				if(c2.x!=0)ans += tem;
				s.push(c1);
			}
			else
			{
				node tem;
				tem.x = m[a[i] - 'A'].x;
				tem.y = m[a[i] - 'A'].y;
				s.push(tem);
			}
		}
		printf("%d\n", ans);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值