题目描述
利用先序递归遍历算法创建二叉树并输出该二叉树中指定结点的儿子结点。约定二叉树结点数据为单个大写英文字符。当接收的数据是字符"#“时表示该结点不需要创建,否则创建该结点。最后再输出创建完成的二叉树中的指定结点的儿子结点。注意输入数据序列中的”#“字符和非”#"字符的序列及个数关系,这会最终决定创建的二叉树的形态。
输入
输入用例分2行输入,第一行接受键盘输入的由大写英文字符和"#"字符构成的一个字符串(用于创建对应的二叉树),第二行为指定的结点数据。
输出
用一行输出该用例对应的二叉树中指定结点的儿子结点,格式为:L:,R:。若相应儿子不存在则以"#"。
样例输入
A##
A
ABC####
B
样例输出
L:#,R:#
L:C,R:#
#include<stdio.h>
#include<malloc.h>
#define MaxSize 1000
typedef struct node
{
char data;
struct node *lchild;
struct node *rchild;
}BTnode;
int i=0;
char sign,str[MaxSize];
BTnode*Create()
{
char ch;
ch=str[i++];
BTnode*b;
b=(BTnode*)malloc(sizeof(BTnode));
if(ch=='#')
{
b=NULL;
}
else
{
b->data=ch;
b->lchild=Create();
b->rchild=Create();
}
return b;
}
void Print(BTnode*root,char sign)
{
if(root==NULL) return ;//空结点返回
if(root->data==sign)//找到指定结点
{
root->lchild==NULL?printf("L:#,"):printf("L:%c,",root->lchild->data);
root->rchild==NULL?printf("R:#"):printf("R:%c",root->rchild->data);
return ;
}
Print(root->lchild,sign);
Print(root->rchild,sign);
}
int main()
{
scanf("%s",str);
getchar();//接收换行符
scanf("%c",&sign);
BTnode*root;
root=Create();
Print(root,sign);
}