Parity game(带权并查集+map离散化)

滴答滴答---题目链接 

Parity game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15826 Accepted: 5982

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

Source

CEOI 1999

[Submit]   [Go Back]   [Status]   [Discuss]

题意:一个长度为N的01串,M句话,每次告诉你a~b区间内有奇数个或者偶数个1,问第一个与前面矛盾的位置在哪,输出他的上一个的位置,没有错误输出M。

思路:因为N为10^9,明显开不了那么大的数组,而M只有5000,也就是说中间会有很多数字没有。我们就想到了离散化,只保存有的数字,没有的数字不开辟空间。对于每个数字需要保存两个值,一个为父节点,一个为权值。用map<int, pair<int, int> >即可,第一个int表示下标,pair中第一个int表示父节点,第二个表示权值(0表示偶数,1表示奇数)。其他的都跟之前的那道食物链的题目基本一样了。

 

#include <iostream>
#include<stdio.h>
#include<map>
#include<stdlib.h>
#include<string.h>
using namespace std;
int n,m,ans;
map<int,pair<int,int> >p;
void init()
{
    ans=-1;
    p.clear();
}
int Find(int x)
{
    if(p[x].first==x)return x;
    int t=p[x].first;
    p[x].first=Find(p[x].first);
    p[x].second=(p[x].second+p[t].second)%2;
    return p[x].first;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        for(int i=0; i<m; i++)
        {
            int l,r,t;
            char s[11];
            scanf("%d%d%s",&l,&r,s);
            l--;
            if(ans!=-1)continue;//已经有错了,只需要把输入即可
            if(!p.count(l))
            {
                p[l]=make_pair(l,0);
            }
            if(!p.count(r))
            {
                p[r]=make_pair(r,0);
            }
            if(s[0]=='e')t=0;//偶数
            else if(s[0]=='o')t=1;//奇数
            int root1=Find(l),root2=Find(r);
            if(root1!=root2)//根节点不同,合并
            {
                p[root1].first=root2;
                p[root1].second=(p[r].second+t-p[l].second+2)%2;
            }
            else
            {
                if(abs(p[l].second-p[r].second)%2!=t)ans=i;//根节点相同判断是否有错
            }
        }
        if(ans==-1)//全对
            ans=m;
        printf("%d\n",ans);

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值