1119 Pre- and Post-order Traversals (30分)

本文探讨了二叉树的前序、中序和后序遍历算法,特别是如何从给定的前序和后序遍历序列推导出中序遍历序列。通过分析算法实现,展示了当仅有前序和后序序列时,二叉树可能并非唯一,但依然可以确定至少一种可能的中序遍历结果。
摘要由CSDN通过智能技术生成

1119 Pre- and Post-order Traversals (30分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

 

#include<bits/stdc++.h>
using namespace std;
vector<int>in,pre,post;
bool uniqu=true;
void getIn(int prel,int prer,int postl,int postr)
{
    if(prel==prer)
    {
        in.push_back(pre[prel]);
        return;
    }
    if(pre[prel]==post[postr])//根结点开始的地方
    {
        int i=prel+1;
        while(i<=prer&&pre[i]!=post[postr-1])i++;
        if(i-prel>1)
            getIn(prel+1,i-1,postl,postl+(i-prel-1)-1);
        else
            uniqu=false;
        in.push_back(post[postr]);
        getIn(i,prer,postl+(i-prel-1),postr-1);
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    pre.resize(n),post.resize(n);
    for(int i=0; i<n; i++)
        scanf("%d",&pre[i]);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&post[i]);
    }
    getIn(0,n-1,0,n-1);
    printf("%s\n%d",uniqu==true?"Yes":"No",in[0]);
    for(int i=1; i<(int)in.size(); i++)
        printf(" %d",in[i]);
    printf("\n");
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值