1119 Pre- and Post-order Traversals(30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

树的前序后序中序,已知一个树的前序和后序,不一定能构成一个树,可能多个。

我们在已知前序和中序的情况下,转换都是通过根节点来判断,但是只知道前序和后序,我们无法判断左右子树具体范围,也就无法得知根节点,本题的要求是任意一种中序遍历即可。

一个树根结点仅会出现在最后一个位置,换言之在划分左右子树的时候,后序最后一个节点为根节点,倒数第二个节点要么为左子树的节点,要么为右子树的节点,一般而言从preleft开始遍历,如果找到第i个节点等于post的倒数第二个节点,若i不是prestart的下一个节点,则i之前为左子树。但是之所以不唯一是因为会出现preleft的下一个如果就是post倒数第二个,那么此时无法判断这是左子树还是右子树,假定为右子树即可。

#include <iostream>
#include <vector>
using namespace std;
std::vector<int> in,pre,post;
int n;
bool flag = true;
void dfs(int preleft,int preright,int postleft,int postright){
    if(preleft == preright){
        in.push_back(pre[preleft]);
        return;
    }
    if(pre[preleft] == post[postright]){
        int i = preleft + 1;
        while(i <= preright && pre[i] != post[postright - 1])
            i++;
        if(i - preleft > 1)
            dfs(preleft + 1, i - 1, postleft, postleft + i - preleft - 2);
        else
            flag = false;
        in.push_back(post[postright]);
        dfs(i, preright, postleft + i - preleft - 1, postright -1);
    }
}
int main(){
    cin>>n;
    post.resize(n);
    pre.resize(n);
    for(int i = 0; i < n; i++)
        scanf("%d",&pre[i]);
    for(int i = 0; i < n; i++)
        scanf("%d",&post[i]);
    dfs(0, n -1, 0, n-1);
    if(flag == true)
        printf("Yes\n%d",in[0]);
    else
        printf("No\n%d",in[0]);
    for(int i = 1; i < n; i++)
        printf(" %d",in[i]);
    printf("\n");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值