1003 Emergency (25 分)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn=1010;
const int inf=0x3f3f3f;
int mp[maxn][maxn];
int v[maxn],num[maxn],p[maxn],vis[maxn],b[maxn];
int n,m,x,y;
void pre()
{
    int t,k;
    num[x]=1;
    p[x]=v[x];
    b[x]=0;
    for(int i=0; i<n; i++)
    {
        t=inf;
        for(int j=0; j<n; j++)
        {
            if(vis[j]==0&&t>b[j])
            {
                //printf("j=%d\n",j);
                t=b[j];
                k=j;
            }
        }
        vis[k]=1;
        for(int j=0; j<n; j++)
        {
            if(b[j]>b[k]+mp[k][j])
            {
                b[j]=b[k]+mp[k][j];
                num[j]=num[k];
                p[j]=v[j]+p[k];
            }
            else if(b[j]==b[k]+mp[k][j]&&b[k]!=0)
            {
                num[j]=num[j]+num[k];
                if(p[j]<p[k]+v[j])
                    p[j]=p[k]+v[j];
            }
        }
    }
}
int main()
{
    scanf("%d%d%d%d",&n,&m,&x,&y);
    memset(vis,0,sizeof(vis));
    memset(b,inf,sizeof(b));
    memset(num,0,sizeof(num));
    memset(mp,inf,sizeof(mp));
    for(int i=0; i<n; i++)
        scanf("%d",&v[i]);
    for(int i=0; i<m; i++)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        if(mp[a][b]>c)
            mp[a][b]=mp[b][a]=c;
    }
    pre();
    printf("%d %d\n",num[y],p[y]);
    return 0;
}

 

 

note

  • Dijkstra 算法
    假设我们要求从A到F的最短路个数和最短路上最大的点权和

example

上图的邻接矩阵表示:
adj[6][6] = \left[ \begin{matrix} InF & 1 & 2 &3& 4& InF\\ 1 &InF& InF& InF& InF& 3\\ 2 &InF &InF &1 &InF& 2\\ 3 &InF& 1 &InF &InF&1\\ 4 &InF& InF& InF &InF&1\\ InF &3& 2 &1& 1 &InF \end{matrix}\right]

点权数组
weight[6] =\left[\begin{matrix} 1 & 2&3&4& 5&6\end{matrix}\right]

每次迭代找到dis数组中最小值,并对与该节点相连的边进行松弛

  1.  
 ABCDEF
w100000
dis0infinfinfinfinf
num100000
visit000000
  1.  
 ABCDEF
w134560
dis01234inf
num111110
visit100000
  1.  
 ABCDEF
w134569
dis012344
num111111
visit110000
  1.  
 ABCDEF
w1348610
dis012344
num111212
visit111000
  1.  
 ABCDEF
w1348614
dis012344
num111214
visit111100
  1.  
 ABCDEF
w1348614
dis012344
num111214
visit111110
  1.  
 ABCDEF
w1348614
dis012344
num111214
visit111111
  • fill 和 memset
    fill 可以填充任何值,包含在<algorithm>
    对vector:fill(v.begin(), v.end(), -1)
    对一维数组:fill(arr, arr + 10, 2)
    对二维数组:fill(adj[0],adj[0]+500*500,inf);
    memset按照字节进行填充,一般用来填充char型数组,也经常用于填充int型的全0或全-1操作,包含在<cstring>
    对数组:memset(a, 0, sizeof(a))
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值