poj 2456 Aggressive cows(贪心+二分

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

思路:

题意要表达的是:把C头牛放到N个带有编号的隔间里,使得任意两头牛所在的隔间编号的最小差值最大。

  • 分析:
  • 这是一个最小值最大化的问题。
  • 先对隔间编号从小到大排序,则最大距离不会超过两端的两头牛之间的差值,最小值为0。
  • 所以我们可以通过二分枚举最小值来求。
  • 假设当前的最小值为x,如果判断出最小差值为x时可以放下C头牛,说明当前的x有点小,就先让x变大再判断;
  • 如果放不下,说明当前的x太大了,就先让x变小然后再进行判断。
  • 直到求出一个最大的x就是最终的答案。
  • #include <iostream>
    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    const int  inf=1e9+10;
    const int maxn=100001;
    int n,m;
    int a[maxn];
    bool st(int d)///中点进入函数,猜测是为了寻找距离第一个牛棚距离大于二分点的有几个,如果都满足,说明二分点符合题意,
    {
        int x=0;
        for(int i=1; i<m; i++)
        {
            int t=x+1;
            while(t<n&&a[t]-a[x]<d)
            {
                t++;
            }
            if(t==n)
                return false;
            x=t;
        }
        return true;
    }
    int main()
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        int l=0;
        int r=inf;
        while(r-l>1)
        {
            int mid=(l+r)/2;
            if(st(mid))
            {
                l=mid;///找到一个符合条件的二分点后进行下一次寻找,放大二分点的值,如果下一个二分点不符合,那么就缩小
            }
            else
            {
                r=mid;
            }
        }
        printf("%d\n",l);
        return 0;
    }
    

     

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值