POJ 1703 Find them, Catch them(种类并查集)

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

 

题意

  • N个人,M条关系,A x y表示询问x和y是不是属于同一组,
  • D x y表示x和y是不同组。
  • 输出每个询问后的结果。

分析

  • 1、所有的关系形成一个连通图,如果x和y可达,那两者关系是确定的,否则不能确定。
  • 2、r[tmpy] = r[x] + r[y] + 1;可以更新连通块里祖先的标号。

eg:

5 4

D 1 2

D 2 3

D 4 5-----到此为止形成两个连通块,标号如图所示(红笔)

D 3 5

第四步,将3和5连边,因为以0为祖先,所以4的标号应当改变,可以发现改变后的r[4] = r[3] + r[5] + 1 = 2 + 1 + 1 = 4;

  • 3、r[5]的更新在Find函数里完成。(Find函数更新原连通块里除祖先外的结点)
  • int tmp = Find(fa[x]);//更新5的原祖先4的权值
  • r[x] += r[fa[x]];//通过加上原祖先4的新权值以完成更新。

 


#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 100005;

struct node{
    int f, r;
};

char s[10];
int n, m;
node a[maxn];

void init()
{
    for (int i = 0; i < n; ++ i){
        a[i].f = i;
        a[i].r = 0;
    }
}

int find(int x)
{
    if (x == a[x].f){
        a[x].r = 0;
        return x;
    }

    int y = a[x].f;
    a[x].f = find(a[x].f);
    a[x].r = (a[y].r + a[x].r) % 2;
    return a[x].f;
}

void merge(int x, int y)
{
    int t1 = find(x), t2 = find(y);
    a[t1].f = t2;
    a[t1].r = (a[y].r + a[x].r + 1) % 2;
}

int main()
{
    int T;
    scanf ("%d", &T);
    while (T --){
        scanf ("%d%d", &n, &m);
        init();

        int x, y;
        while (m --){
            scanf ("%s%d%d", s, &x, &y);
            int t1 = find(x), t2 = find(y);
            if (s[0] == 'D')
                merge(x, y);
            else{
                if (t1 != t2)
                    printf ("Not sure yet.\n");
                else{
                    if (a[x].r == a[y].r)
                       printf ("In the same gang.\n");
                    else
                        printf ("In different gangs.\n");
                }
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值