POJ 1080 Human Gene Functions

Human Gene Functions
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16979 Accepted: 9438

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. 
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. 
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity 
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of 
the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal 
length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix. 

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the 
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 

Source


题意:已知一个人类基因的积分表,给出两个字符串,计算这两个串的最大相似程度;

思路:最长公共子序列的变形,用score[][] 表示积分值,dp[i][j]表示字符串s1[1,2,,,i]和s2[1,2,,,j]的分值,对一个dp[i][j],有三种可能:

> s1取第i个字符,s2取‘-’时,dp[i][j] =dp[i][j-1]+rt[getint('-')][getint(b[j])];

>s1取‘-’,s2取第j个字符时,dp[i][j] = dp[i-1][j]+rt[getint(a[i])][getint('-')];

>s1取第i个字符,s2取第j个字符时,dp[i][j] =dp[i-1][j-1]+rt[getint(a[i])][getint(b[j])]);

取上述三个数的最大值即是dp[i][j];

注意初始化也与LCS不同,

dp[0][0] = 0;

当i= 0时,dp[0][j] = dp[0][j-1] + rt[0][s2[j]];

当j = 0时,dp[i][0] = dp[i-1][0] + rt[s1[i]][0];


#include <stdio.h>
#include <string.h>

int rt[5][5] = {
    {5, -1, -2, -1, -3},
    {-1, 5, -3, -2, -4},
    {-2, -3, 5, -2, -2},
    {-1, -2, -2, 5, -1},
    {-3, -4, -2, -1, 0}
};

int getint(char c)
{
	if(c=='A')
		return 0;
	if(c=='C')
		return 1;
	if(c=='G')
		return 2;
	if(c=='T')
		return 3;
	if(c=='-')
		return 4;
}

int max(int a,int b,int c)
{
	int num=a;
	if(a<b)
		num=b;
	num=num>c?num:c;
	return num;
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{	
		int dp[105][105];
		int x,y;
		char a[101],b[101];
		memset(dp,0,sizeof(dp));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		scanf("%d%s",&x,a+1);
		scanf("%d%s",&y,b+1);
		dp[0][0]=0;
		for(int i=1;i<=x;i++)
			dp[i][0]=dp[i-1][0]+rt[getint(a[i])][getint('-')];
		for(int i=1;i<=y;i++)
			dp[0][i]=dp[0][i-1]+rt[getint('-')][getint(b[i])];	
		for(int i=1;i<=x;i++)
			for(int j=1;j<=y;j++)
			{
				dp[i][j]=max(
					dp[i-1][j]+rt[getint(a[i])][getint('-')],
					dp[i][j-1]+rt[getint('-')][getint(b[j])],
					dp[i-1][j-1]+rt[getint(a[i])][getint(b[j])]);
			}
		printf("%d\n",dp[x][y]);
			
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值