uva 10168 summation of four primes

Problem A

Summation of Four Primes

Input: standard input

Output: standard output

Time Limit: 4 seconds

 

Euler proved in one of his classic theorems that prime numbers are infinite in number. But can every number be expressed as a summation of four positive primes? I don’t know the answer. May be you can help!!! I want your solution to be very efficient as I have a 386 machine at home. But the time limit specified above is for a Pentium III 800 machine. The definition of prime number for this problem is “A prime number is a positive number which has exactly two distinct integer factors”. As for example 37 is prime as it has exactly two distinct integer factors 37 and 1.

 

Input

The input contains one integer number N (N<=10000000) in every line. This is the number you will have to express as a summation of four primes. Input is terminated by end of file.

 

Output

For each line of input there is one line of output, which contains four prime numbers according to the given condition. If the number cannot be expressed as a summation of four prime numbers print the line “Impossible.” in a single line. There can be multiple solutions. Any good solution will be accepted.

 

Sample Input:

24
36
46

 

Sample Output:

3 11 3 7
3 7 13 13
11 11 17 7


Shahriar Manzoor

“You can fool some people all the time, all the people some of the

time but you cannot fool all the people all the time.”




看别人的,哥德巴赫猜想!


#include <cstdio>
#include <cstring>
#include <cassert>
#include <cstdlib>

#ifndef ONLINE_JUDGE
#define debug_printf(...) (printf(__VA_ARGS__))
#else
#define debug_printf(...) (0)
#endif

const int PRIME_SZ_MAX = 10000000;

bool is_prime[PRIME_SZ_MAX];

int prime[PRIME_SZ_MAX / 2];
int prime_sz;

void generate_primes()
{
    memset (is_prime, 1, sizeof (is_prime));
    for (int i=2; i<PRIME_SZ_MAX; ++i) {
        for (int k=i+i; is_prime[i] && k<PRIME_SZ_MAX; k+=i) {
            is_prime[k] = false;
        }
    }

    prime_sz = 0;
    for (int i=2; i<PRIME_SZ_MAX; ++i) {
        if (is_prime[i]) {
            prime[prime_sz++] = i;
        }
    }
}

void solve()
{
    int n;
    if (scanf ("%d", &n) == EOF) {
        exit (0);
    }

    if (n < 8) {
        printf ("Impossible.\n");
        return;
    }

    int a, b, c, d;
    if (n % 2 == 1) {
        a = 2;
        b = 3;
    } else {
        a = 2;
        b = 2;
    }

    c = -1;
    d = -1;
    for (int i=0; i<prime_sz; ++i) {
        c = prime[i];
        d = n - a - b - c;
        if (is_prime[d]) {
            break;
        }
    }
    assert (c != -1 && d != -1);

    printf ("%d %d %d %d\n", a, b, c, d);
}

int main (int argc, char **argv)
{
    generate_primes();
    debug_printf ("Done!\n");
    debug_printf ("%d primes generated.\n", prime_sz);

    while (true) {
        solve();
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值